Materials won't save. Model pubishes completely white


(Aialexander) #1

Hello! I've been having an issue where every time I try to save the settings on a specific model I want to upload I get an error saying that something went wrong and the materials couldn't be saved. I then tried publishing in the hopes that the materials would be saved when I published and that proved to be unsuccessful. My model has 5-6 material groups, and the textures are 4k, but I've also tested this with lower res textures and got the same result. I don't know why it only happens with this specific model. Can someone please help me understand what I might be doing wrong?

You can find the model here: https://skfb.ly/68VyP. The thumbnail is what it looks like with all the materials applied, but it always loads white.


#2

Hmm, is Substance the last step in your workflow? Could you try uploading directly from there? https://sketchfab.com/exporters/substance

I was able to apply one texture and save correctly. Maybe try clearing your browser cache/cookies?


(Aialexander) #3

Okay, I tried clearing some of the cache and cookies, and reloaded the model, and I got 1 texture to display out of the 20 that I uploaded, but it was better than nothing. I also stopped getting the error message about the materials and was finally able to save them once I got them all loaded in again. Thank you for your help!


#4

Glad you got it working! Sorry for the inconvenience.