Sketchfab Forum

Materials won't show up in List

materials
textures

(Colorofblack) #1

Hey everyone,

I'm currently working on a "bigger" scene.
I uploaded it and iteratively fixed problems by reuploading the model (Chaning mainly material names and creating single material instances where I had the same material used on many objects)
This worked really good until I fixed the last few mistakes I had in the scene.

I reuploaded the file and every material I already had asigned was gone. This would have been annoying if I simply could have reasigned the textures to the materials (there are a lot of them)
But somehow there are only 2-3 Materials left (I had way more before and they showed up fine)
No matter which version of the fbx I upload now, even the old ones that worked fine, the material slots won't shop up.
Does anybody have an idea why this is happening and how to fix it?

I also imported the fbx into Substance Painter and the material slots show up there just fine...

As I need to have my model done until tomorrow it would be great if anybody could give me a hint why this is happening.

Cheers
Daniel


(Colorofblack) #2

Seems the problem is: More than 100 Materials :wink:
This is stated in the Help files. Though it would be nice to get some feedback directly when uploading a file :stuck_out_tongue:

Cheers
Daniel


(Waleguene) #3

Hi @colorofblack,

As you probably read, when the limit is reached, in a first step we try to merge all similar materials together, and if it's not enough, we "force" merge all the materials into one.
This is something unexpected most of the time, and we are aware of the lack of feedbacks in this case. This is something that will be improved :slight_smile:

Thanks for reporting