Maya 2020 FBX export not containing Hardware Texturing

Greetings,
I’ve converted a Maya 2020 file to FBX but the Hardware Texturing does not appear with it, so all the Textures are now white. Textures are .jpgs. It also appears all white when uploaded to SketchFab and I don’t see any options for this in Sketchfab. I also don’t see any options for this in the Maya FBX options menu so I’d appreciate a solution. I’ve tried both converting an .ma and .mb file and same results

Hey!
FBX file doest hold texture files. What you need to do is save all your textures and upload them into the Sketchfab.

You can also use a plug-in to export all files from Maya to Sketchfab automaticly

I’ve tried all those suggestions but the uploaded model continues to lack Textures. The Downloaded Exporter would not open for me so I created a Zipped folder containing the .FBX and Textures and drag/dropped into the Upload. The Transfer completed but after it Processed, the model was all white. I still think the problem is that the Hardware Texturing is not present.

Can you share your files? I can have a look tonight

Thanks- I sent the files via We Transfer. I think the problem is in the
.FBX conversion process- when I re-open it in Maya, the Textures are
present but Hardware Texturing is turned off and mesh is white. In Maya
I see no option within the .FBX options regarding Hardware Texturing,
only Embed Textures which I’ve enabled. I’ve contacted Maya Forum but
received no answers- also looked online but no help- only info on Embed
Textures. Maybe the Textures have to be .tiff or something else besides
.jpgs ?

Please see attachments for what I’ve tried so far, thanks!

Here’s the problem in Maya-

When the converted .FBX is opened, the Textures are present in the
Hypershade, but Hardware Texturing is turned off, preventing the
Textures to be visible. With Hardware texturing turned on, the Textures
appear. I’ve tried re-saving the .FBX w/ Hardware texturing activated,
but it reverts back to turned off. Until I can figure out what’s causing
this, I won’t be able to upload anything onto SketchFab. Could you
possibly ask another Maya artist about this? I’ve looked online and
can’t find any info about this, thanks

On 2020-03-12 09:35, Warkarma via Sketchfab Forum wrot

OK, I believe the problem is in the auto assigning textures to the correct material slots. Also, keep in mind Sketchfab uses PBR or Specular workflow.

  1. As I can see you have all the textures uploaded with the model. So you just need to re-assign them.
    I made a short video on how to do this.
    https://youtu.be/u7c4ajHKdi8

  2. If you would like Sketchfab to auto assign your textures to the correct slots they should be named like this:

MaterialName_suffix.extension
for example:

  • Material1_albedo.png
  • Material1_metallic.png
  • Material1_roughness.png
  • Material1_ao.png
  • Material1_normal.png
    etc…

I hope this helps!

Thanks- In re-reading some SketchFab info I was able to load the
Textures thru the Material loader- it’s not very apparent on the UI, but
I was able to load them afterall

2 Likes