Missing Texture when uploading to sketchfab(exporter)

Hey friends,

I’m new here. Trying to upload my first low poly model for my project.

I’ve uploaded my model succesfully : https://sketchfab.com/models/901a488142b446679bb68a1d2d422b4a/edit using the exporter .
( followed this video: https://vimeo.com/68497644 ).

Now in 3ds max it looks like this:


So now you see what is missing and the whole render doesn’t seem to look that great in sketchfab.

I do not now what is causing this. Asset tracking should be set correctly aswell:

Someone who knows what going wrong here ? would highly appreciate!

kind regards

I don’t really understand what is the problem. Can you be a bit more specific? Can you take screenshots and mark the area of the problem?

2 Likes

hey! Thanks for the reply.
I’m sorry if this is the case. This was not my intention.

The problem is: when I upload my model from 3ds max into sketchfab there seems to be missing texture. And some texture appears very blurry. :

This is how it looks like in max :

As you can see from this image the wall texture is missing in sketchfab. I thought this was due asset tracking but I don’t think this is the case. As I think it this is set correctly (as shown in previous posts screenshot).

Hopefully that clears it up. If you have any further questions please don’t hesitate to let me know.

kind regards

I think this is because you bake light when exporting.

OK, thank you. now I can see what you are talking about.

There is a texture on the wall. You can see it if you go to Model Inspector “i” and pick Diffuse material, channel.

I am guessing it doesn’t show the texture in a final render because you have a Vertex Color. It looks like the parts which have white Vertex color are being rendered correctly and the wall has dark color for some reason and it doesn’t show the texture :thinking:

Now, the texture shows blurry probably because it has too small texture size. And after Sketchfab optimization it looks not as good as the original. What is your texture size? I would check, but the model is non-downloadable and UV inspection is disabled.

wow thank you! it was indeed the vertex color being turned on that was causing the texture to not show up in the final render.

I’m not sure why you are not able to inspect the models UV since ‘Allow texture inspection’ is turned on: image.
(unless there is something else i have to do to make this possible that I’m not seeing?)

I’ve made it downloadable aswell now.

Texture size is 512x512:


It has decent texture space as far as I know. I don’t think it’s supposed to be blurry

Hey , thanks for the reply!
I think this happens automatically when using the exporter. maybe i should try uploading using zip

just turn off “bake lighting” in the exporter.

1 Like

Yeah, 512 is a good texture size, but for small things. If you would compare your texture it would look like this.

There are two solutions to this.

  1. Make a bigger texture size such as 4096x4096 or even better 8192x8192
  2. Make it modular. It’s basically making loads of blocks of the building and later combining them all into one. They can use 512x512 but they all need a separate texture. Though you can use the same texture on many of them and you can play around with UV to get a different effect

1 Like

Looks like just disabling vertex colors was the solution?

Yes, for some reason Vertex color was masking the texture. Or it was just overlaying it :thinking:

1 Like

Yes, vertex colors are multiplied by the texture, so it can have unexpected results, especially if the vertex colors are black.

2 Likes