Mobile AR issues

android

(Twitte King) #1

Hi i tried to search for similar topic but no luck, sorry if i am repeating someone else's question.

I just got my samaung galaxy s8, i installed the sketchfab app, i went to the linked github page and installed the tango AR core. i tried to start AR view on different models, Sketchfab crashes/ closes everytime... i have submitted a feed back on googleplay with system log as well a few moments ago. any idea how to fix this? thank you in advance.


#2

Hmm that's not good. Can you try restarting your phone, closing all other apps, etc. to see if that helps?


(Twitte King) #3

I restarted reinstalled sketchfab today No luck...


#4

Strange. I'm afraid I don't have an S8 to test :confused:

It happens on any model, even really simple ones?


(Twitte King) #5

Yep even this one...:tired_face:


I opened your reply on Android chrome,
I tap the sketchfab icon on the viewer for the blue cube to open it in the sketchfab app, then tap the ar option there is the screen shot.

Another attempt gives me a sketch authorization website, but it takes infiNitely long to load

https://sketchfab.com/oauth2/authorize/?client_id=gM1NZwFRTZv9xFq4DswM5HYINDh2P7PWNkAhO5xt&response_type=code&redirect_uri=sketchfab://login

Dunno if that's a thing thanks again for the quick reply


#6

Ouch :confounded:

@arthurjamain any idea?


(Falce003) #7

Same problem on a Pixel 2 XL here. Cube doesn't work either :cry:


(Rémy Bouquet) #8

From your screenshot it's not clear what's not working. AR is only available through the sketchfab App, but seems you experience crashes even in regular view from the browser.
Do you confirm that any model crashes from the website? Not only when you try to go in AR mode? Was it working before you installed the Tango AR app?


(Twitte King) #9

i am sorry if the image was confusing, i sent it to indicate that i did opened the sketchfab app, and then it crashed immedietely after i tap the AR option, then android tell me the app had stopped.

but as i mentioned, i did open the model with the sketchfab app, and i went thru the tango AR core thing.

thank you for helping in advance!


(Twitte King) #10

so sad


(Twitte King) #11

please help!! i was really looking forward to testing my scenes with AR once i got my new phone! is the android log i sent wt=ith my google play bug submittion help ful? if you guys cant find it i can do that again!!


#12

Sorry, we’re still investigating!


(Llaniewski) #13

Same here on S8+. The app crushes on any model, when I tap “AR” icon.

Any way I can pull out logs to send you to help with the bug?

The AR feature would be a great addition to our visualization at our University. But for us to be able to rely on SketchFab, that would need to work on a range of phones (phones that students have). We would love to say to students “install this app, tap on this model, tap AR and see the flowfield around this car” :slight_smile:

I tried Augment, but their 3D model editing/support is crappy - sketchfab is way better at rendering a nice model.


(Twitte King) #14

thank you guys very much for still looking into it, considering how busy you guys are with the store launch and stuff!!


(Twitte King) #15

I know right! i am also very interested in using Sketchfab for my 3d modeling class for University and maker space!


(Twitte King) #16

So I updated the sketchfab app today, saw ar core update… Sketchfab app tells me my device is not supported. I click the more info link, and saw the ar core support device list, my phone being smg 9500 is not currently on the list( a variant for the whole China market).

https://developers.google.com/ar/discover/#supported_devices

http://www.phonemore.com/compare/phones/samsung-galaxy-s8-sm-g9500-vs-samsung-galaxy-s8-sm-g950u/5341525

Guess not only me, all of China’s Samsung users are out of luck! No ar,:tired_face:

I am hoping it’s only a software thing and in time they can expand the list to include smg9500, it’s such/ a shame my flag ship phone got thrown under the bus…At least for now…