Sketchfab Forum

Model Animation Problem C4D


(Wunderkind) #1

Hey,

im new to animation, not sure if i do it right, the animation doesnt work. maybe someone could take a look. thanks for ur time :confused:

C4D file and fbx in onedrive


(Waleguene) #2

Hi @wunderkind,

Thanks for reporting this, and also for sharing your source files, that's really helpful!
From what I see, the issues seems to come from how the affecting bones are organized within the graph.

On Sketchfab, we consider a skeleton as a continuous set of bones (or animated null objects affecting the mesh as bones), and following this "rule", your models has more than one skeleton affecting your character. Naming them by their root node:
- root,
- l_fuß
- r_fuß

Sketchfab will only take into account one of these skeleton (according to the first bone found in the FBX object skinning modifier) , and it should explain the result you got on Sketchfab.

As workaround, I could suggest you to create a new bone at the top on your three "skeletons", and then add root, l_fuß and r_fuß as children of this new bone. By doing this, we will consider all your bones to belong to the same skeleton and the animation should work.

I hope it helps, keep us in touch!


(Wunderkind) #3

thanks for ur quick and detailed answer. i tried a lot, but couldnt get it to work. when i upload, the character just shows up in the standart pose


(Waleguene) #4

It is working in C4D but not on Sketchfab right ?
If yes, could you do a quick test: export the file in FBX and reopen it in Cinema4D to check that everything has been exported correctly ?
And if this step is ok, could you point me to the corresponding Sketchfab model ?

We will end up with it little dude walking as it should do :smile:


(Wunderkind) #5

Hey,

i tried and its not working correct, after reimport in C4D as fbx file. (everything moves correctly, but the foots stand still – just seesaw a bit.in scetchfab nothing happens: https://skfb.ly/JYF9
thanks for ur time again (:


(Wunderkind) #6

so finally i got a fbx, that works in other applications too (tested with 3ds max) – changed the hierarchy, now it has one skeleton.

but its still not working in scetchfab ): new fbx in onedrive