Sketchfab Forum

Model Appears Shadeless While "Lit"

lights

(Oakeshott) #1

For some reason, the model I am currently working on does not appear to show any lighting or reflection. The strange thing is it appears just fine in the editor, but it is when I save and exit that it now appears flat and lifeless. It was working just fine for several weeks, but just recently started exhibiting this issue. I had temporarily resolved the issue by switching from PBR to the classic renderer and back, but now it is back in the problem state.
I was scheduled to release this model to my Patrons today, so I was hoping that I might be able to resolve this issue soon. Thanks!

Dale


#2

Hi Dale,

We recently had some issues with texture optimization. I just triggered this model to be reprocessed. I hope it will solve the problem.


(Oakeshott) #3

Thank you for the response! I have tried uploading the model again, and am still having the same issues with both the previously uploaded version, and this current version. I have found that if I go into the editor and adjust some settings, then return them to their previous state, it will temporarily fix the problem, but not for more than about an hour. Is there anything I can possibly do to tackle this issue?

Thanks again,

Dale


(Nomadking) #4

Perhaps you could post a screenshot of what your seeing in the editor, it would be useful for comparison to figure out what’s changing.

The model you linked is definitely lit, but in quite a subtle way - you can see this by opening the Model Inspector and swapping between Final Render and Base Color.


(Stephomi) #5

Sorry for the bug!
Something wrong with the roughness, we’re investigating.

Edit : @oakeshott there’s an issue with srgb colorspace set on greyscale channel.
You can fix the issue by setting the textures in linear space.
As a side note, I strongly advised to keep the textures in “auto” : roughness and metallic are typically authored in linear space in 99% of 3d softwares.


(Oakeshott) #6

That would do it! Thanks for the help! I will let you know if I have any more issues with it.