Model import geometry issue

3dsmax
upload
3d

(Kirkmullis) #1

I'm having a weird issue where my model geometry is getting messed up on the import. I am trying to upload an apartment interior and the geometry that i have created to cap off the walls gets offset some how. I am using 3ds max and exporting an fbx. I have tried resetting xform, converting to editable poly, and attaching it to other objects in the scene. I'm really at a loss at this point. Any suggestions as to why this might be happening would be greatly appreciated.

This is how it looks in 3ds max

This is how it looks when it gets imported into sketchfab


Geometry moved a bit after upload
#2

Looks like it's related to our geometry compression. We're investigating.


(Mrchlblng) #3

@kirkmullis this is an issue with our custom geometry compression. We do not detect that geometries should be aligned, use different parameters in a lossy step and end up with a shift in positions.
We are still iterating on compression which is a tough subject, especially on complex scene so it's hard to give any ETA as to when we would be able to fix this issue.

In the meantime, could you make sure that you have at least one point in each geometry snapped at the same position?


(Kirkmullis) #4

Thanks for the response. I definitely have the points snapped to the same location. I drew out the wall cap with snaps enabled and then added an edit poly and snapped all the points again to make sure. This is probably the best web app I've seen for viewing 3D models online and I have messed around with webgl and html5 so I know what a challenge it can be to get things optimized and compressed correctly. Thanks for looking into this and best of luck


(Kirkmullis) #5

I figured out that converting the offending geometry into an editable mesh inside of 3ds max before exporting to fbx fixes my geometry problem.


(Mrchlblng) #6

I'm both puzzled on why just changing the "type" of geometry fixed the issue and happy you found a solution!
We'll look to understand why this fixes your mode. Thanks a lot for letting us know!