Sketchfab Forum

Model meshes are smoothed too much on edges

blender
upload
3d

(Vladimmi) #1

I have some models to show my skin paints, but they look deformed on meshes edges and parts connections, like smoothed too much. Check this models:
https://sketchfab.com/models/0bb0cc1ada404ac38c838e0d98dfd595 (sides, where ORSRL logo)
https://sketchfab.com/models/3ef04b87dd4f45f1b3cd29a2bb368a77 (sides, near GameStul, rear wing sides)
https://sketchfab.com/models/224411f38bd548f19db69d31fd5b4974 (rear wing sides)
They should look more "sharp" and "flat", compare to Blender renders:


Is it something wrong with models or Sketchfab processing?


#2

Hey,

We're having a hard time figuring out what the issue/difference is here. Can you show us an exact comparison screenshot between Blender and Sketchfab for one of the models and geometries?

Thanks!


(Vladimmi) #3

Sure, I'll make and post comparison screenshots with details at home at evening.


(Vladimmi) #4

So here it is. My english is a bit bad and it's difficult to describe all the terms but I'll do the best to show you what I mean :smile:

As you can see on screenshots, places where two parts connect are "bumped" around that junction. But if you look at Blender renders, this places should be absolutely flat with just a junction line without any relief. Screenshots differ in lights but I hope you understand what I mean.
Used model - https://sketchfab.com/models/0bb0cc1ada404ac38c838e0d98dfd595
If you rotate it and look from other angles (for example, parallel to car side) you can see that model geometry is really flat so that "bumps" maybe some wrong lighting, bump maps or something.


#5

Great, this is much clearer! Thanks!

I'm not sure if it's a problem with blender import. @marc @waleguene


(Shaderbytes) #6

I can tell by eye that in the blender render the edge is split. In Sketchfab the edge is joined , since the face angle along these joined edges is steep you get this shading artifact.

How are these edges defined in the blender scene , did you mark them sharp and are you using an edge split modifier? If not , blender is kind enough to still perform the edge spit when rendering based purely on the marked edges , but when exporting a model the edge will not be split unless you manually split it or have a edge split modifier ( The sketchfab exporter add on for blender will call to apply modifiers automatically if you are using that ) if you are exporting an .fbx you get an option to choose to apply modifiers or not.

hth


(Vladimmi) #7

Well, I'm not a 3D-pro and that model is ripped from game (I just paint them, making race car skins). Can provide blender file if that helps - that one I've uploaded to Sketchfab.


(Shaderbytes) #8

yup send me the blend file and I will have a look for you


(Vladimmi) #9

https://goo.gl/M2DxNu


(Shaderbytes) #10

cool thanks , yes autosmooth was being used on this model, plus all the edges are marked sharp which is not helpful for exporting but there should be a way around this,

you can add a edge split modifier onto each object , deselect "sharp edges on the modifier window so its only using the angle, then set the angle to 60 deg. This should in theory export as expected then. Im doing a quick test for you first its busy uploading.

(I did not add a modifier to each object , I joined all the objects and added the modifier onto that)


(Shaderbytes) #11

ok that almost worked 100% , I didnt even check it in blender I just uploaded , I see only one edge still , behind the drivers head somewhere was not picked up by the modifier. Maybe you can see others anyway you can play around with the edge angle yourself to see what works best , there might not be a best angle for all and then you need to manually split ( or remove all the sharp edges and redefine which edges should be sharp and then you can use re select the sharp edges option in the modifier.)

car example by shaderbytes on Sketchfab

this model will be deleted once you have seen it


(Vladimmi) #12

Thanks you very much, looks almost perfect! I'll try to correct my models.


(Shaderbytes) #13

Sure no problem , just to recap :

so I used a edge split modifier , deselecting "sharp edges" option and edge angle of 60 deg

Also I de-selected autosmooth for the objects.

With this process you only have the one edge still not working , for this I would personally enter edit mode select all and remove sharp edges , then for these few edges not been split by edge angle , mark them as sharp , then on the modifier include splitting on sharp edges again

cheers


(Vladimmi) #14

Thanks again, advices in topic helped a lot. Just one difference: while fixing edges that do not split by modifier, I prefered to not alter whole model (to prevent some possible new problems) with making all edges non-sharp and returning sharp to selected ones. Instead I just selected problematic edges and made manual "edge split" from available edge operations. Worked like a charm, model looks perfect now!