Model Orbit / Rotation Problems


(Ocuair) #1

Hi, None of the models I have uploaded to SketchFab seem to be orbiting properly. I would like them to rotate around a centre axis but I can't figure out how to do it? Am I missing something obvious?

I would like all of my landscape models to behave like this one:

https://skfb.ly/CLs6

Please see below for the models which I cant seem to get working:

https://skfb.ly/CVow
https://skfb.ly/HXDZ
https://skfb.ly/HXDZ
https://skfb.ly/HXDZ

Thanks in advance.


(Moroplogo) #2

Before upload your model, make sure that it is already well centered.
If not so:
- From your model, go to Settings → 3D Settings.
- Select the Scene panel in the top left.
- Double click in the center of your model , choice your zoom to view all or one part of your model and save your changes by clicking on Save Settings. You can also change your thumbnail by clicking on Save View .
Then we can rotate around this.

Please read these topics :




#3

Can't really improve on @moroplogo's answer :smile:

The "advanced rotation" tools are definitely what you need. I've done it for you on the clock tower model:

Belton Clock Tower by Ocuair on Sketchfab


(Cmj Francis) #4

I am also having this problem and I have tried the solutions here to no avail...
This is my model that is not rotating the way I would like (horizontal, flat):

Coulter Cabin B by cmj.francis on Sketchfab

Please help.
Thank you,
Chris Francis


(Moroplogo) #5

Click on "3D settings" and click the arrow buttons (X , Y and Z ) to reorient your model and manipulate it to see if it is right for you.
You can see and test with this downloadable model (created with Blender) :

testorientation by moroplogo on Sketchfab


Below a screenshot of blender file


#6

@cmj_francis

Hi Chris,

I've made a quick video showing you how to fix the up-axis / orientation / navigation for that model. I hope it helps!

And the result:

Coulter Cabin B by cmj.francis on Sketchfab


(Opuspix4d) #7

My model here does not orbit around its centre either https://skfb.ly/QAyn . I tried going into the 3D settings and centering the model by double clicking while on the Scene tab and then saving. But it made no difference. Any ideas? Thanks


#8

Double-click the background. Move/zoom the model where you want it. Click Save View.

I just did it for you on that model.


(Opuspix4d) #9

Thanks James. I'm not sure what I was doing wrong. You say 'double click the background', I was double clicking on the model, so you've actually got to double click on the background instead?


#10

Double-clicking the model will focus the camera and rotation on that point. Double-clicking the background resets the camera and rotation to the center of the model's bounding box. There's a video here:

Hope it helps! :slight_smile:


(Opuspix4d) #11

That's great. Thanks James.


(Achaikin) #12

The important thing to remember is that the horizontal plane of your model should be parallel to Sketchfab's reference plane (which you can see by checking "Show advanced rotation" in the 3D settings area). First step is to grab the reference plane, make it horizontal. Then, using the "X" "Y" and "Z" adjustments, rotate the model until its horizontal plane is parallel to the reference plane. To do this precisely, you can click on the trackball to activate one specific axis at a time, then nudge the model in that axis until it's in the right orientation. Then click "Save settings." Hope this helps!


(Cs Chris) #13

Great posts everybody, very informative. Now we know how to get the models to rotate around their center.

My problem is, I like to pan. When I pan the object, it still seems to rotate around the screen's center. Which very quickly means I am now rotating it off the screen. The model is lost.

I can double click to bring it back, but our customers viewing this on our website will not know to do that.

How can we set the rotation axis to always be the center of the object? Even after panning it?

Thanks


(Freakingeachin) #14

Now that is what I call a good answer. Clear, to the point and effective. Thanks, I was lost before I read this.