Model quality looks far different between on program and sketchfab viewport

Metashape Viewport ->


Sketchfab uploaded ->

This is my model on Viewport, but as I uploaded this into sketchfab viewport, what should I do to make the rice good as upper one?

There are two things to fix:

  • Change your scene from ‘lit’ to ‘shadeless’ (scans already include lighting information)
  • Disable vertex colors - Metashape exports both the vertex colors AND the texture maps, leading to ‘double coloring’:

Here’s how it looks afterwards (the bloom effect that you added makes it very hazy)

2 Likes

Thank you so much! Model looks more realistic and nice!!!

1 Like