Model Scale issue from FBX 2019 format

Hello, Sketchfab Team.
I am using 3d’s max 2019 and have workflow setup “millimeters”.
Character 3d model has 1100 millimeters height.or 1,1 meters. And has T pose.
I am exporting model in FBX 2019 ASCII format and leave Units setup “automatically”.
So when importing the model in sketchfab, the camera zooms very closely to model’s feet. Which is already gives an idea there’s something wrong with a scale.

I start rotate model in sketchfab and decide to look how hands on that T-pose are looking like. And I see that the fingers of the model when they are facing camera, they are slicing through the camera and I can see the inside of the model through fingers that way.

image

I go back to 3d’s max to set scale from automatically to meters. And it doesnt help, same issue. I set it even to millimeters in 3d’s max. As my workflow, still doesnt help, i even set workflow to meters to export with automatic units or others, still doesnt help. But the thing i’ve notticed it gives an influence to VR view. So if I set my 1000 mm model units to meters or kilometers in VR view it becomes even larger but it doesnt affect anyhow the regular browser view.

I tried to scale my model in VR 3d settings.

But it did not affect browser view scale (when 3d settings saved and i open the regular page with model) still…

Thing is when I Import the Obj file it scales ok, but i want to import FBX because it has some animation. I don’t know what to do… I think from my 3d’s max side it’s all fine.

Have you tried resetting the XForm on max? Most of the time it fixes everything :smiley:
The steps I would do to try and fix this:

  1. Select the model and reset the XForm
  2. Upload it to SF and see if anything changed
  3. If scale is still shit, I would rescale the model down and reset the XForm again
  4. Upload it to SF
    XForm location
1 Like

I am afraid to reset XForm on some objects because they intended to be rotated with some degree to build a pose, things like cartoon-like positioned teeth and tongue, they might have XForm reset but it would affect animation and specially rotation within local axises… Also Reset XForm screwing up the bones rotation.

Upd: Well, Thanks to warkarma. Actually i had to reset XForm of certain few objects on scene to get it right, thankfully not the whole model.

No problem. Next time always reset XForm after modeling. 3Ds Max is stupid like that :slight_smile:

Glad you got it working.

FWIW, the Sketchfab viewer is unitless, so choosing a unit in your software should not change the result on Sketchfab.