Model wont render with textures


(Smellypete) #1

Hi,

been having trouble getting a model to display properly with textures. I've uploaded a .zip containing my .blend file and my painted UVs to sketchfab but after it uoload the model comes out with a fully reflective/chrome surface. after multiple attempts i cant get this to work right.. any suggestions?

Also the model does appear correctly and textured in Blender when I saved the file


#2

This usually happens if you you're using Cycles nodes, because they don't play nicely with our renderer when exported. If you're preparing a file for Sketchfab, it's usually best to use Blender Internal.

Quick solution is to apply the texture in 3D Settings and reduce Specular and Glossiness:

One of our Masters might be able to give you advice for preparing your textures in Blender.
@shaderbytes @elbriga @chaitanyak @saphires ?


(Chaitanyak) #3

thanks @james
@smellypete this is the workflow i usually follow for models I know will be going on sketchfab.. avoid cycles, because you'll have to recreate all your materials and lighting in sketchfab..

I see your textures have loaded, thats good.

now for the wood material i usually use these settings:
I prefer tweaking the "Metalness" to the "Specular" but you can try either.
Ultimately i use "Roughness" to reduce the fidelity of the reflections..

and for metals i do this:
for these kinds of metals i reduce the "specular" and keep the rest the same..
for metals "roughness" is a great setting to play with, if you turn it down to zero you get chrome like highly reflective metals.. and adding something under 30 gives you a dulled metal look.. cranking it up will make it like brushed metal.

these are just my examples, feel free to experiment on your own as well.