Models textures renders black on Android

Hej

I have problems with my animated scarf texture renders black on Samsung galaxy s 22 in Chrome and Firefox. The texture is 1200 x 1200. The low-res texture shows for 1 second and then it turns black. Works great on PC in Chrome.

Please help!

Thanks

Henrik

Can you try with all post processing off ?
if it works then try to find by setting them one by one until it makes the bug reappear ?

Hej

Thank you Paul for the quick reply.
I have tried turning off processing and it did not help.
Also tried uploading part of the scarf model with a 256 x 256 texture and sill it renders black.
Rand the webgl report as well(see image below)

I have the same problems with other models as well. this one for example.

Ps. I’m running Android 12

Thanks

Henrik

Ouch very strange. Does it render black too in shadeless ?
(or using the model Inspector => Base Color)

It renders base colour.

1 Like

Facing the same issue. Watch tutorials on YouTube but didn’t resolve.

I got the samsung s22 ultra.
And all models are black, both on the website and inside the app from googleplay.

Hi Paul

Any progress on this issue?

Thanks

Henrik

We’re getting the necessary hardware so that we can reproduce the bug, hoping to be able to give news in a few weeks

Hej Paul,

Any progress?

Thanks

Hemrik

we have the hardware, we reproduce the bug, now digging on gpu driver idiosyncrasies and how to mitigate it without breaking viewer for all others. Working on it, hard to give a timeline until we have the full solution

Hi @paul_sketch, I just replaced my phone with a Samsung S22 after my S20 fell overboard. I am having the same issue with all sketchfab models rendering black on the S22.
Also having strange issues with the Vuforia AR app on the S22.
Wondering if it is might be an issue with Samsung rather than Sketchfab


Preview

Final Render


Matcap View

UV Checker

Wireframe View

@paul_sketch Hi Paul, thanks for all of your hard work. Do you maybe have an update related to this issue?

Thanks,
Bart-Peter

Yes we tracked it to a part of handling texture (only happens with material with trilinear settings)
Working on finding a way to fix it only on GPU where it fails.
Thanks for you patience

1 Like

I’m having the same issue (model texture turns black) in Chrome on an Android Vivo phone. Looks fine on laptop. big burrow in K04 complex - Download Free 3D model by Hal Brindley (@halbrindley) [a8e7245] - Sketchfab

O meu acontece a mesma coisa mais eu uso prisma 3d nao tenho computador não consigo sabe o porquê o modelo fica preto as vezes fica metade preto ou meio pixelado e uma bagunça

Samsung Galaxy S22, same problem here

From what I see there is not the slightest interest on the part of either Samsung or Sketchfab to fix the problem. Money wasted on this S22 Ultra, no more.