Modo Exporter error SSLv3 issue

modo
upload

(Nicmeier) #1

searched everywhere but couldn’t find a solution. wanted to try the Modo sketchfab exporter but can’t login at all. I checked the event log and saw this error:

OUT:URLError = [Errno 1] _ssl.c:504:error:14077410:SSL routines:SSL32_GET_SERVER_HELLO:sslv3 alert handshake faliure

I’ve tried several versions from 11-12 and on both windows 10 and MacOS.
Modo_Sketchfab_Error


First Time Modo User
Upload error in MODO 10.2
(Robtag1) #2

Same error here. Hello, any feedback on this?


(Waleguene) #3

Hi,

We recently had similar issues with our other exporters. It’s due to Python using a TLS certificate that is not supported anymore for security reasons (you can find some context here)

I’m not very familiar with Modo but I guess the plugin is using TLS protocol from some local python packages and depending of the version that is setup on your machine, it uses a supported or not supported version of this protocol.

Could you run these commands in a Python interpreter to see which version is used ?
(using cmd.exe for Windows or ‘Terminal’ on OSX, typing “python” and Return)

import urllib2
import json
r = urllib2.Request("https://www.howsmyssl.com/a/check")
result = urllib2.urlopen(r)
resultjson =json.loads(result.read())
print(resultjson['tls_version'])

Keep us in touch,


(Nicmeier) #4

Result:

Traceback (most recent call last):
File “”, line 4, in
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 126, in urlopen
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 400, in open
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 418, in _open
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 378, in _call_chain
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 1215, in https_open
File “/workspace/modo_linux/extra/python/osx/Python.framework/Versions/2.7/lib/python2.7/urllib2.py”, line 1177, in do_open
URLError: <urlopen error [Errno 1] _ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version>


(Robtag1) #5

This is the result on the MacBook I’m running Modo 12.1v1 from
TLS 1.2


(Waleguene) #6

Hi,

We have more info about what’s going on as we reproduced the issue locally.
We recently implemented Cloudfront for all traffic on all of our domains, which updated our SSL/TLS allowed protocols.

One of these updates requires Python 2.7.7 or higher, but Modo seems to use Python 2.7.3, so login doesn’t work anymore.

We contacted The Foundry in order to know if there is a way to upgrade the Python version for Modo, and we will keep you posted.

Sorry for the inconvenience,


(Robtag1) #7

Hello, I’m trying to upload using modo 12.1 and I get this error.


#8

I’ve discussed the issue with The Foundry team. Modo 12.2 will upgrade Python to 2.7.14 which should solve this issue. I’ll keep you posted when testing becomes available.


(Robtag1) #9

Hello, I have the same problem, login doesn’t work on 12.1