Sketchfab Forum

Morph issue

animation
upload
3d

(Dethjester17) #1

This still seems broken for me. Here is an example of the normals flickering. I just uploaded this FBX.

The blend shape is only on the eyes and nose area. I purposely painted out the rest of the vertices to make sure there was no vertex movement outside the eyes and nose. You can see the ear area flickering. I don't know if it has to do with FBX export and floating point math. But when I bring it back into Maya and crank the blend shape to 10+ you don't see any vertex movement in that area. Any help with this would be greatly appreciated.


Normal map color space issue
(Kristaps R) #2

I don't think that normals flickering. I think that's just incorrect morphing. Can you make it available for download so I could see whats the problem?

Do you have multiple blendshapes on the mesh? I have noticed such problems start to happen when there are more then one blendshape on the mesh.


(Dethjester17) #4

Should be available for download


(Kristaps R) #5

You used Paint Blend Shape Weights Tool? If that's so , then it seems FBX doesn't support Blend Shape weights, because when I imported your project it looks exactly like in sketchfab.


(Dethjester17) #6

I painted them out then duplicated the mesh, and remade the blend shape before export. There should be zero movement on the ears. Are you seeing movement in the ears when you import the fbx? Because when I download my mesh back from sketchfab and load the mesh into Maya, and crank the blend shape to 10x its normal value I see zero movement in the ears. But if you turn on wire frame and zoom in on the ears and then watch the animation on sketchfab the ears flicker. Even the wire frame moves. This seems to happen on any blend shape animation I export. It also seems to be more noticeable in areas that have strong changes in direction like noses, lips, ears etc.

What 3d software are you using? Its possible this is a floating point math issue.

Thanks for checking this out.. much appreciated Kris

-m


(Kristaps R) #7

Happy to help.

Now I see what you mean. I use both maya and modo and animation works fine there. It does seem it's a sketchfab bug. I guess you should create new topic and report it, because this is not the issue I was reporting in this topic.

To better demonstrate the issue I would recommend uploading version with blend shape cranked up to 10 as you told. I tested it here on sketchfab and the bug is much more noticeable that way.

Good luck,

Kristaps


#8

@dethjester17 I'll move these posts to a new thread for you - thanks.


#9

@mrchlblng @waleguene


(Mrchlblng) #11

@dethjester17,

it seems to partly be a compression issue.
When I reprocess your model without geometry compression, the ear vertices are all static as expected. However, the normals are still moving a bit and I'm not sure this the intended result (as it makes the shading still "flicker"). I confirm they're not moving when opening the FBX in 3dsmax.
So I'm not sure how to fix/bypass the issue on your sample :confused: