Multi-FBX + Animations

Hello people,

I’m coming to you because I’m having some troubles to upload Multi-FBX animations.
As you know, there is this interesting feature that allow us to upload some kind of stop motion models :

I read the several posts about it but couldn’t solve my issue, so here I am.

The thing I’m trying to do is to export 3 differents models (upgrade of a building) while each one of them have an animation.

So I’m wondering, is it compatible with Sketchfab ?

For now, it seems that I have the good hyerarchy :

    - animations
       - Tier1.fbx
       - Tier2.fbx
       - Tier3.fbx
    - sketchfab.timeframe

I also tried to add a .fbx version of my models (non animated) at the root of the .zip as describe on the previous tutorial.

But the only result I had despite several tests is that my animations are not working and my 3rd (last) animated model isn’t even showing.

Just to let you know, I already tried to upload each one of my model separetly with their animation on sketchfab and they all display correctly, so the problem is comming from the .zip upload.

If you have any advice or solution I would be grateful :pray:t4:

Hi @crouzet.charlotte.8 !

With the “multi FBX” technique, all your models will be loaded at the same time, so you do not really have a memory gain compared to do one unique file with all your building’s versions within.

Did you consider the idea to animate the scale of your buildings ? 100% for your “active” state, and 1% for the others (0 will return an error), and you alternate ? You could animate the change in less than a frame and that will be invisible.


Owh good idea @YannickDeharo,

I guess I’m gonna do as you said, just wanted to try different options that purpose sketchfab.

I think that I also already saw a model that purpose to click on 3 different states of the model to switch between each one of them but cannot find it again to show it to you, does it remind you something ?

Anyway thanks for your answer once again !

1 Like

Hi !

I know that you could do a lot of interactive things with Sketchfab. But I can’t help you on this, sorry, it’s beyond my skills ^^ ! I think you have to code something for this end… Or you can search in Sketchfab’s lab if it exist something that can help you…:

For a “State selection” you could do a “multiple track animation” with one state each time. So the viewer can decide to launch all the animations in a row, or to loop the one of his choice.

Just as you did for you “Blow Gunner”

Yes but that’s not worth it for this upgrade animation, there is only one idle.

It’s just that I remember to see 3 different images on the bottom of the sketchfab file, so the vewer could select one model at a time to switch, but as I said I cannot find it…

I’ll give a look at your link thank you !

My book is almost done, discovering all the nice possibilities of sketchfab, will improve my knowledge with the time :wink:

1 Like

Have you gave an eye to Sketchfab’s lab ? Is there something like this for example:
It could be a good basis…

Indeed, it might be something like this !

This must be a texture switcher but it’s a good basis, gonna do some searches.

1 Like

A last link and I go back on my modelling. The band model changes here too. Not just the material.

1 Like

Nice ! How do you do to find this and answer so fast ? haha

Thank you very much, I think I have everything I need to find a solution for my project !

You rock ! :pray:t4:

1 Like

I simply looked at the titles of the different experiments which belong to Sketchfab’s lab, in my first link ^^!

While I was opening each one of them to see what this lab purpose haha
It was the last one indeed …

Enjoy your modelling !

1 Like

It always be the last one :slight_smile: !
(Unless if you begin your research from the end!)

Thank you ! Don’t forget to put a link to your result on the topic, so I could see ^^

1 Like

Hi again !

• Well, after making a lot of researches, it seems that the API feature (that allow a lot of interesting parameteriazation of the models) is only usable on websites, and not directly on the sketchfab platform.
And as these are simple models that I just want to share on ArtStation, it’s not worth it for now to get into Javascript coding.

At least I have plenty of ressources for the day I’ll want my own website to show the models !

• So, last night I tried to animate the scale of my models, but I have an unwanted interpolation, while the scale is supposed to use only 1 frame, no matter the fps of the animation and the rate of baking.
I even tried to scale AND translate my models to -5000, but the result was that one of the models was not showing, depending on which frame was done the scaling + translate :crazy_face:
This issue is apparently known by the developpers who are still working on it. according to this post : Animating objects on and off via scale

• So I’ve been wondering if it was caused by maya, so I exported my animation on Max, animated my scales and… I have the same result as on Sketchfab : the scaling is only on one frame, but when I play the animation I see a quick interpolation of the scaling… :crazy_face:

> Did you ever animated a scale on 3ds Max ? (I’m not very familiar with this software anymore…)
> And if yes would you have any advice to avoid this interpolation at least on Max?

Sorry to ask it derctly to you, but couldn’t find many posts about scaling issue on the forum except the one I shared ealier…

Otherwise, I guess I may do a new post about this issue, just in case there would be a solution on another software than Maya and Max…

I just want to do a simple scale :sob:

1 Like

What you are saying about the scale sounds familiar to me:

  • “Frame per second” export FBX error
    That was a problem I meet before and this topic was mine, but I found a solution. The problem came when I was baking the animations, all of the animations keys became “Linear”. My will was to animate each transition “stepped”.
    That was because I animated the scale on one unique curve. Not one for each X, Y and Z “channel”. That is the “by default” option of 3DS Max. but you can change this and redistribute your informations on 3 curves before baking. That will fix the problem. On 3DS Max, you can follow this:

If you animate the scale of an object, make sure to use a ScaleXYZ controller. By default, 3DS Max plans the use of Bezier Scale, but this setting offers one unique curve for the scale animation. However, when you exports in a FBX file, this curve is imperfectly copied into the 3 curves of a ScaleXYZ. The position of the keys is kept but not the Stepped or Linear setting which is standardized according to the “Default In/Out Tangeants for New Keys”. All of the keys become instantly “Stepped” or “Linear”.
If you animated the scale on a Bezier Scale controller, you can fix it before the export :
A- Clone your object as a simple copy.
B- Change the controller of your former object to ScaleXYZ. (Your keys will be standardized)
C- Select the Bezier Scale curve of your clone and copy it. Then, past it into the 3 curves of your original object (which now has a ScaleXYZ modifier). That will keep all the richness of the curve.
D- Delete your clone and that’s it! Your model is ready for export!

1 Like

You said the magic word !
Switch to a stepped interpolation instead of linear.
It worked perfectly on Maya. Just needed to overlap the transitions on 1f to avoid a white blending but it diplay as wanted now.

Thank you once again :pray:t4:


Okay ! So you haven’t any stepped frame before ? I gone far with my problem of 3DS Max ^^ !

No I set it on linear, only used stepped interpolation for blocking in animation, didn’t think about it for this issue, now that you said it it seems pretty logical…

Also Maya always work with the 3 curves of the transforms (as far as I know), so no troubles with the software reinterpreting the animations by changing it to 1 curve.
I think that Maya is way more optimized for animation than Max, or it’s a question of habbits but… this is not the debate here :wink:

And I always bake my models and bones before the exportation since the several issues I had on my characters, this way I’m sure to have no issue…

1 Like