New Wordpress-Sketchfab Embed

wordpress
embed

(Sazberryftw) #1

Hello,

It was recently announced that WordPress.com now supports Sketchfab embed (yay!). However, the blog post states all you need to do is paste your Sketchfab model URL into the visual editor and it automatically embeds, but this doesn't work for me.

http://blog.sketchfab.com/post/139114425579/wordpress-now-supports-sketchfab-embeds?utm_source=website&utm_campaign=newsfeed_news_block

Can anyone help?
Thanks
Sarah


#2

Hi Sarah,

Sorry to hear that :confused:

Could you post a screenshot of your editor and the result?

James


(Sazberryftw) #3

In the visual editor on my portfolio project: http://puu.sh/nlkqQ/f6afe50698.jpg
When I preview the page on my website: http://puu.sh/nlktZ/8eaef75177.jpg

It literally just stays as the link. :frowning:


(Miekeroth) #4

Sometimes it can be a silly thing like a forgotten "enter". Your site is update to the latest version of wordpress?


(Sazberryftw) #5

I made sure to press enter. :smile:
Not sure about the latest version - where do I find this out?


(Miekeroth) #6

If you are not sure where to find it, that could be it. In your dashboard in wordpress it should be announced that there are updates. Your wordpress should be on version 4.2.2. This number should be displayed on the openingspage of your dashboard.


(Sazberryftw) #7

Does this apply to WordPress.com sites? I don't see anything on my Dashboard relating to version 4.2.2.


(Miekeroth) #8

Ah, no. I thought they are handling it differently. Have to check but it's midnight over here.


(Sazberryftw) #9

No worries!


(Jvouillon) #10

Hi, your link is displayed fine on my WP. It must be an update problem.


(Chaitanyak) #11

@sazberryftw the wordpress.com sites dont need to be manually updated.. its always running the latest version. Its only if your using wordpress on your own hosting.. that you need to manually update it. Infact going to the wp-admin dashboard wont even display the version anywhere.

heres sketchfab working on one of my posts https://chaitanyak.wordpress.com/2016/02/24/what-did-we-leave-behind-on-the-moon/

however i noticed, you have to wait a few moments for the proper preview to show up in the editor.. ie:

In the wordpress.com editor
step 1) paste the link
step 2) wait for the link to turn into the sketchfab model thumbnail
step 3) publish(if you publish before the thumbnail appears, it just posts as a link)
kindof like when we paste a link in facebook

Note:
In the wordpress.com wp-admin editor its a little different.
the inline preview does not appear..and you don't need to wait for it.. it works when you publish/preview

to get to the wp-admin ediitor on the wordpress.com site
click on the link at the bottom left of the screen

or go to this link(replace my username with yours)

hope that helped.

UPDATE:
the wp-admin dashboard's editor seems to support the Sketchfab iframe embed code!
all you need to do is create a new post, then switch to the "text mode" and paste it here

then when you switch back to "visual" mode, it gives you a placeholder object to do your layout around.


(Sazberryftw) #12

Thanks for the reply! I used the iframe embed code in the text editor and it appeared in my editor like your screenshot, but it doesn't appear on the updated site. Once you update, it turns back into a link both on your published site and the editor.

As I am working with a portfolio, I can only edit on the wp-admin.

However, I also tested it on one of my pages through the wordpress editor (not admin) and the link still didn't change into the Sketchfab 3D viewer on the editor, but it does work once you publish!

It seems to be a problem with editing through wp-admin!


(Chaitanyak) #13

hmm.. @james do you think it could be a problem with her template/theme ?
@sazberryftw could you quickly change themes and see if that helps at all?


(Sazberryftw) #14

Do I lose anything if I change themes? I don't really wanna have to fix everything later when I change it back.


#15

@chaitanyak I'm afraid I have no idea :confused: I've never used WP >_<


(Chaitanyak) #16

@james thats ok, i just use it as a backup mirror for my blogger blog anyway.

@sazberryftw i applied the theme and it works fine.. so am guessing its some configuration youve added somewhere..
this is mine https://chaitanyak.wordpress.com/
if you can spot what i havnt enabled/modified.. that might be it.

maybe you could create a temporary account and test on that?
am sorry, but i think this is the extant of support you can get from us right now.
keep us posted incase you make a breakthrough, in case someone else is also having this issue.. it may help them.


(Sazberryftw) #17

Thank you so much for the help guys! It's been really useful. I'll take a look and see if I can find why it's not working on mine.

@chaitanyak Have you noticed that some of your Sketchfab embeds don't work on your blog? Not sure if that was on purpose or not.

UPDATE: I made a new test wordpress with the same theme and was able to display them fine. So currently looking into any customisation I have done to my site. :blush:

UPDATE 2: I think I have found why! On my actual site (sarah-akers.com) I created a blank portfolio project. On this project, the Sketchfab viewer worked. There seems to be a conflict with the Sketchfab embed and basically doing anything to do it (centering it, having too close to other images etc). Unless the link in the editor is completely untouched it won't work.


(Chaitanyak) #18

aah so some answers finally :smile:

yeah that wordpress blog is an automated backup of my blogger blog.. the automated posting system screws up the links.