No image display in Samsung S7. All black in all models


(Darius Vr) #1

Hey guys, so I ve been using sketchfab to deliver a 3d model, but I just realized that my phone , Samsung Galaxy S7 just can't show any model at all, everything appears black, no texture display, light , nothing. Any thoughs???, I already reset the phone settings and uninstall Firefox and Chrone beta, really don't know what could be.

Thanks


Model appears completely black on firefox for Android
(Leroymerlinbrasil) #2

I have the same problem in my S7, is it possible that sketchfab has changed something?


(Gilles38) #3

Hi @darius and @leroymerlinbrasil ,
I am having the same issue.
A while ago, I had an issue that had to do with dark models with Firefox and Samsung S7 although it wasn't identical and Chrome was working fine but this time it's all dark and even Chrome is failing to display properly the models.
It was working with Chrome yesterday but not today. Hope the staff will find a fix.


#4

I'm afraid we don't have an S7 test device. Could someone please use remote debugging to check the console for errors?


(Misan) #5

Same problem here. Unfortunately, for the life of me I could not get the remote debugging working on my S7 (USB debug is enabled but remote device is not detected by Chrome in Linux). I will try later with OSX.


(Geromy) #6

My S7 is having the same issue as @dariusVR . @james I'm willing to try with remote debugging.


(Misan) #7

@james I finally get remote debugging to work but it took some persuasion plus using the original USB cable that came with the phone.


Black screen is shown instead of the intended animation. Just 3D scenes (no animation) cause the same result. Fun thing is my older S6 was working perfectly with all your site. Please let me know if you need any additional data from the remote debug.

I am adding the console log file too: console.log (43.5 KB)


(Gelbuilding) #8

I have the same problem on my S7.
On my sketchfab model in the browser rendering is shadeless, though when i select a colour you only see the mesh of the model.

Unbelievably it works on the Ipone 5, go figure why this is possible.


(Stephomi) #9

Thanks, we are investigating the issue.


(Virtuder) #10

I think this is also related to my problem


Recently google implemented an update, that VR in sketchfab needs to be viewed in Google VR, that can not be downloaded to some of the older phones...
I wanted to use Samsung Galaxy S8 with Gear. It worked with S6, but doesn't work with S8 (can't test it with S6 now)...


(Ripvannik) #11

Same issue on my S7edge.
Look forward to hearing if there's any progress.

Cheers.
Stephen.


Problems with Samsung S7
(Geromy) #12

@james Did Sketchfab do something on their side? Everything seems to be working fine on my S7 now. How about the other users?

Would you still like me to debug?


(Misan) #13

@Geromy1 it seems to work in my S7 too as far as I browse a 3D model but 3D animations are still a black screen on mine. Can you try this animation and tell me if it works on your S7?

A by misan on Sketchfab

Thanks a lot,

misan


(Geromy) #14

@misan

Black screen on my S7 for your model as well and only visible with wireframe enabled.
On the other hand, it doesn't run smoothly on my pc too.


(Misan) #15

@Geromy1 thanks for testing it. It works ok on my PC (though animation files seem more taxing than 3D models on my system).


(Geromy) #16

@misan

No problem. I would like to hear from Sketchfab if further debuging is required :slight_smile:


(Darius Vr) #17

Hey, so after some days, now my S7 can display the 3d models with Chrome, but wont show any models with animations attached.

Altough, I'm really impressed that I can run a 800k poly model on my S7, I will try to push it a little bit.


(Gelbuilding) #18

Finally got my model showing up on my S7.
Go To your chrome browser and type in
chrome://flags/
and enable webgl

Plenty of different options here, scroll down to bottom of the page and work your way back up
to find webgl

Make sure to hit RELAUNCH NOW at bottom of screen


(Gilles38) #19

Hi @gelbuilding,
Happy that it works for you. I have an S7 too and Chrome is working fine but not Firefox. Do you think it could be the same problem?
Can you tell whether Firefox is displaying the models as you expect on your S7 ?
Thanks a lot.

PS: here is the issue I have that Sketchfab didn't solve so far


(Gelbuilding) #20

Hi Gilles38,

I installed Firefox on my phone and my model didnt show up clear,
I suppose you have to find out how to setup webgl as i did in Chrome.

Try this:

Firefox

First, enable WebGL:

Go to about:config
Search for webgl.disabled
Ensure that its value is false (any changes take effect immediately without relaunching Firefox)
Then inspect the status of WebGL:

Go to about:support
Inspect the WebGL Renderer row in the Graphics table:
If the status contains a graphics card manufacturer, model and driver (eg: "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine"), then WebGL is enabled.
If the status is something like "Blocked for your graphics card because of unresolved driver issues" or "Blocked for your graphics driver version", then your graphics card/driver is blacklisted.
If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

Go to about:config
Search for webgl.force-enabled
Set it to true
(Like Chrome, Firefox has a Use hardware acceleration when available checkbox, in Preferences > Advanced > General > Browsing. However, unlike Chrome, Firefox does not require this checkbox to be checked for WebGL to work.)