No image display in Samsung S7. All black in all models


(Misan) #21

my older S6 was working perfectly with all your site

I take it back. Now that I have tried, 3D animations do not work on the S6 either (just a black screen with a moving blue circle along the time line), but regular 3D scenes do.


(Misan) #22

It is been quiet in this thread for a while.

I have noticed that animations work ok in my S7 if I keep the number of faces low. Same scene with more faces turns into a black screen. I guess there is some memory limit somewhere. But it is surprising that several sub-$200 Xiaomi cell phones are not so picky as Samsung's.


(Gilles38) #24

Hi @misan, it's kind of surprising indeed.
I can barely watch more than 2 models in a row with my S7. After that I get a error message saying there is probably not enough memory. If I turn my phone to get the lanscape view in ful screen, I get the same error message.
It seems to me that this was working quite well some months ago...


(Misan) #25

Hi @gilles38,

My S7 won't even show me a single animation, but it usually shows me 3D scenes, even more than two. I reckon my S7 has gone through several firmware updates (official firmware).

But I am a bit disappointed no more progress is being done in solving this issue. It is preventing me to deploy some tech to some users as I cannot rely on them not having S6 or S7 phones (after all Samsung is one of the leading brands in the Android market).


(Gilles38) #26

Hi @gelbuilding and @misan,
I went through your instructions @gelbuilding and it looked OK, WebGL is enabled and the WebGL Renderer row says ARM--Mali-T880.
As @misan said, it is quite frustrating because people won't spend time chekcing their WebGL status on their phone...
I found out that the Sketchfab app on my phone was reponsible for this landscape crashing problem I mentionned earlier with Chrome on my S7. Using the Sketchfab website, everything is fine (with Chrome, Firefox still showing lightless models). What can we do ?
Hope this will improve soon...


(Ripvannik) #27

Hi. Just picking up this thread again, to see if there have been any developments.

I set both firefox and chrome up to run web gl, but the same problems persist.

My models only have vertex colours on them as opposed to any material files, as they typically have well over 1m vertices which means a huge image file needs to be produced.

I can see the wireframe, but no colour data mapped on to it.

Maybe the software is looking for a material file that does not exist ? I have no problem on the laptop though.

Let me know if this works on your phone please ! https://skfb.ly/6sKFU

Cheers !


#28

That model is very heavy - 1.8 M polygons. I'm surprised your phone can load it at all.


(Ripvannik) #29

Ok James, thanks for the reply.
After i got your message yesterday i went back and looked at this in my S7: https://skfb.ly/68MWp

This has roughly half the polycount and it loaded ok over my home wifi, but when I checked again today it's back to black again..?

For the record I have viewed the heavier model load in an old htc one8..so it is an issue with the S7 from what i have seen.

Cheers.
Stephen.


(Ripvannik) #30

Update: The 1m Poly model works in an HTC one8 in firefox, and , iphone 5s and iphone6 in Safari without a glitch.

On the S7, Ive tried firefox, samsung internet and chrome. Same results: Black model.

S.


(Kiwimage) #32

Hello, this model, which was exported from substance painter directly, appears black on Firefox for Android phone. (Galaxy S7, FYI)
However it is correct elsewhere, on Android-Chrome, and also OK on Firefox for windows PC.


(Bart) #33

I've merged your message into the existing topic about display problems on Samsung phones.

@james, @stephomi do we have any updates about this issue?


#34

I did not dig much more, but it seems to be a Firefox-specific issue as far as I can tell?


(Kiwimage) #35

Indeed @james, I just picked 3 random models on sketchfab.com, each one of them is pitch black on Firefox, and looks just fine on Chrome.