Sketchfab Forum

No shadows on iPad


(Marcbell) #1

I searched but couldn't find any information.
I don't have any shadows when viewing on the iPad.
They work great on Android and Desktop.

Thanks in advance.


(Paul Sketch) #2

It is disabled: WebGL on Iphone/Iad (ios) has a sad & strange hard limitation: a "8 active texture at once" limit.
Real Time Shadow Casting does add 1 Texture per Light whereas the texture units is already filled withmodel textures (by channel) and environnement texture as it is.


Shadows don't work anymore on iOS