Sketchfab Forum

Normal map artifacts


(Skazok) #1

Hello.
I can see artifacts on my sword and on another models, even on models that is not mine. I would think that it is because we do some thing wrong with settings but here is one strange thing… When I open 3d setings it looks good. Here is screenshots of 3d viewer in common mode and in 3d settings mode.

And that is a link on this model. https://sketchfab.com/models/d763bf37ddbd413690b75c6efd289ec0
May be it is only in my browser… Please say if you see it different.


(Dekro) #2

I see no artifacts, even tried looking at more of your uploads and saw none, so i’d guess it’s probably from your end browser related, just a wild guess.


(Skazok) #3

Thanks :slight_smile:

My OS is Linux.
I think it may be because of propriatry AMD drivers. Stable version are not officially released for Ubuntu 18.04 yet, but without it Substance Painter will not work properly, so I have to use this drivers.


#4

Link to the model?


(Skazok) #5

https://sketchfab.com/models/d763bf37ddbd413690b75c6efd289ec0

It seams that problem is on my side, almost all models, not just mine has this artifacts for me. I think it may be cosed by unstable drivers that I use.


#6

Can you please send me a screenshot of this report? http://webglreport.com/

Do you see the same result in different browsers? Have you tried upgrading your GPU drivers?


(Skazok) #7

Here is screen shots in both browses that I use, but now I deleted amdgpu drivers. With drivers that is on default in Ubuntu I do not see this artifacts, though I think That there is steal some subtle imperfection but not critical. In 3d settings mode it steel looks a little better than in common mode.

To make webGL work I had to uncheck using black list of hardware in browser settings. May be I just need new video card.

Yeas The issue is shown in different browsers.
The issue appeared after I installed amdgpu driver. I need this driver to make substance painter work. Now I removed it and and problem is solved.



#8

This is most likely due to the texture optimizations we do for the regular viewer.

I’m really not sure about the issue with the GPU / driver. Maybe @paul_sketch has some insight.


(Skazok) #10

Thank you for your help.
Now I know that the problem is on my side and I know that with right drivers it works well.

It seams that texture optimization + amdgpu driver causes this problem.