Obj file: two meshes into one error

upload
3d

(Raven Pencil) #1

Hi! I’ m at my second update in absolute.

There are two meshes (the compass and the ring attached to it) that should be on their own and instead they are viewd as one, with the consequence that when the texture is applied it’s a mess. I thought there were a problem with my exporting program (Blender3D), but I tried re-importing the averall and it works.

I had the same problem with my first uploaded model
Someone can help me please?


#2

Hmm. Have you tried uploading the .blend file directly instead of exporting OBJ?


(Raven Pencil) #3

Nope, from what I understood reading Sketchfab guide for uploads, obj format is read correctly and others formats are a so so. Maybe it was a bad interpretation from my part.
I’ll try in acouple of days and let know

Most thanks for answering by the way


(Raven Pencil) #4

I’ve tried, apparently it doesn’t solve the problem. I removed the parent constraint too, just to see


(Waleguene) #5

Hi @RavenPencil,
Could you share the original Blend file with us so that we can check and get more info of what’s going on ?

Thanks,


(Raven Pencil) #6

You can find it here


(Moroplogo) #7

I downloaded your file and the texture associated with the compass . Here is the result obtained in blender .

I suppose , you may be able to solve your problem by changing the place of the mesh or choosing another name for the texture of the ring.


(Raven Pencil) #8

Well, the ring of the compass has its own texture, the problem is that when I upload the file on Sketchfab the compass and ring meshes are merged together. From what I see, into the file you downloaded the two meshes are apart (as it should be), so I suppose the source file has nothing wrong…
The issue is not about textures (I believe), since I manually added them after with Sketchfab in-functions.