Obj files not letting me edit all materials/objects individually


(Jdilaa) #1

I'm having a really strange problem here. I uploaded a model earlier already in .obj format (the model is in 7 pieces) and everything worked fine, I uploaded all of my textures and everything was working perfectly, except one of my objects had reversed normals so I went back and fixed that in Maya and re-uploaded it. But now I don't have access to all of my models/materials anymore, when I double click somethign the entire mesh is just selected as one object and I only get one material (Material_0).

It was working fine earlier so what's the problem?


#2

Hmm, there should be a MTL file associated with the OBJ file. That's how different materials are defined and we are able to separate them in the editor.

1) It's not with the OBJ you uploaded
2) There are no references to either the MTL file or actual materials in the OBJ

I just tested and confirmed that Maya exports the MTL correctly with its objexport plugin, as long as you enable materials in the export options.

You could also try FBX.


#3

Or better yet, the Maya Exporter plugin: https://sketchfab.com/exporters/maya


(Jdilaa) #4

Thank you the plug-in worked really well. However I'm now having a new problem (or the problem that required me to reupload my model in the first place persists.)

For some bizarre reason one of my assets is coming out transparent, the odd thing is that it's a duplicate of another mesh on my model (it's a shoe.) I tried reversing normals but that didn't help, why might this be happening?


#5

Hmm, can you send a screenshot or something? I'm having trouble figuring out what you mean on that model, and I don't see any transparent meshes (well...i guess that's the point >_< )


(Jdilaa) #6

I managed to fix it in Maya but I still have an old version with the error so maybe you could take a look just for future reference if anyone else has the same problem?


See the sandal on the left? it's kind of a cloudy translucent.