Object casts shadow in AR (iOS)


(Btd) #1

Is it possible that an object placed in AR (iOS) casts a shadow on the floor?


#2

It's something we're working on!


(Aleahy) #3

Hi James, in the mean time are there any tricks/shortcuts for creating a shadow plane under the model?

We're really enjoying being able to place design concepts in AR.

Andrew (Alf) Leahy | Western Sydney University


#4

You could use a flat plane with transparency:


#5

This will be implemented in our next release. In AR, we'll remove lighting from the scene and add lighting from above to cast shadows on a plane below the model. This should make the models look less like they are floating.


(Btd) #6

Sounds great, I'm looking forward to that!


(Laurent Imasud) #7

Hello,

Any news of this flat plane with transparency ?

I try to do something like that, but it doesn’t work on other background than plain white :confused:
If you implement an option to do that automatically, it will be great.

Regards.


(Mauricesvay) #8

Hi @laurent.imasud,

if you get the latest version of the Sketchfab app (for Android or iOS), models should automatically have a shadow when switching to AR.


(Laurent Imasud) #9

Hi @mauricesvay

Thank you for the info for the sketchfab app.
Is there a way to have the same thing on PC ?
Maybe I missed a button somewhere to activate that transparent plane ?
Regards.


(Mauricesvay) #10

Hi @laurent.imasud

It’s only available for mobile AR at the moment. We’re not doing it on PC, because it would interfere with the lighting.
On PC, I still recommend you to add the plane yourself. It’s the best way to keep control over its rendering and lighting.


(Laurent Imasud) #11

Hi @mauricesvay

ok thanx.