Object transformation animations displaying incorrectly for .glb file

I uploaded two .glb files to Sketchfab earlier today:

https://sketchfab.com/models/826d2f4c7c95487694c43a2d99247b38
https://sketchfab.com/models/ff83e11e6bd54ecd9302500917991ece

(These are renderings of a bespoke order for a client business, so I’ll not be sharing the source files publically, nor will I be publishing the above drafts until this glitch is resolved, for obvious reasons.

If the Sketchfab team can’t access the original files from the above links, then please message me so I can DM them if ncessary.)

I exported the files using Blender 2.82a.

They display fine in this offline three.js viewer that I’ve been using, and which the Sketchfab team has apparently also been using as a standard:

https://gltf-viewer.donmccurdy.com/

But the animations are completely messed up on Sketchfab.

None of the objects ever reach where they’re supposed to be, they all drift endlessly and in the wrong axes even though they’re supposed to be stationary for most of their curves, they suddenly congregate seemingly at the scene origin and then suddenly with zero rotation, etc.

Exporting to .fbx instead is not a viable option because the Blender exporter for it seems to take much longer (due partly to insisting on baking every action). I haven’t tried uploading a raw .blend yet, but I’d like to avoid it as that’s a much more opaque format (and, in fact, takes so long to process that it times out). The entire reason for gltf existing is so that this kind of thing doesn’t happen anymore, and this feature should work in any case.

Are there any backend issues in Sketchfab that are causing this? Are there any reasonable technical workarounds that I could take to successfully upload these animated models despite it?

Right, I managed to get both files to work fine when uploaded as .glbs that had every keyframe baked and keyframes outside the animation range removed.

The original behaviour is still broken though, and baking keyframes inflates the file size, complexity, and opacity considerably. Consider this post only as a bug report, and not a support request, I guess.