Oculus GO - Sketchfab Support HELP

oculus

(Domingos) #25

I’ve found that if you select the “Request Desktop Mode” in the top right-hand corner of the browser window (in the Oculus Go), then the quality is resolved. However, the refresh rate is poor - nowhere near as smooth as the low res version :frowning:
Pros and cons


(Lpdenmark) #26

There is also more problems to viewing Sketchfab on Oculus Go.

The controller doesn´t work.
The size you set with the VR-dude is not displayed correct.
There is black areas in the border of your viewing area.
(seems the app try not to render areas you don´t see,
but you do :slight_smile: Think the Oculus Go have a vider viewing
area than what is rendered.

Hope to see a fix for these artifacts.


(Infinitemethod) #27

We’re also currently working with a large company on possibly integrating their products into Sketchfab, and the ability to then use an Oculus Go to view their models is a large part of whether or not we’ll be moving forward with this project. This will be a win-win for both Sketchfab and business development teams if you guys can knock this integration out of the park.

Best of luck, and thanks for your hard work!


(Vrchris) #28

Low resolution when viewed in VR via web browser has been a problem since day 1 and it still has not been fixed.


(Iillee) #29

Is anyone else having problems viewing models on the Go? Since last week, every time I try and load a model in VR the browser reloads and I get a “page has crashed and been recovered” message.

This is a huggge problem for me as sketchfab is the only way I can view my models in VR. Please let me know if you’ve had the same problem and have found a fix.


(Lpdenmark) #30

Yes, I have the same problem.

A week or two ago I could use the Oculus Go, but whit limited
succes. Since then it seems like there has been changed something,
because now it just reloads the page.


(Dan) #31

Thanks for all the updates and attempted fixes here!

We’re still keeping an eye on this forum although, unfortunately, there is not much to update yet at this time. Our devs are aware of the issues as well. Right now, it is a matter of priorities and bandwidth.

As soon as we can offer an update, we’ll be glad to share it here. Thanks again for your patience!


(Lpdenmark) #32

Hi Dan

Thanks for the update :slight_smile:

It´s still strange that the Oculus Go works perfect in the VR app where you can view a few selected models, even the Oculus Go controller works perfekt in the VR app.

Look foreward to find out the mystery secret about this :slight_smile:


(Mauricesvay) #33

The Oculus app was made when the first VR headset were launched. It was meant to be a showcase app only. It uses a different 3D engine that can not read Sketchfab models. The built-in models had to be converted and reworked heavily to provide a good experience.

Since then, WebVR has been introduced, making it possible to have a VR experience with Sketchfab 3D engine. We prefer to focus our efforts on our own 3D engine, that’s why the Oculus app is unlikely to get an update.

Hope that helps solve the mystery.


(Lpdenmark) #34

Hi Maurice

Realy thanks a lot, that explains the case very good.

I couldn´t understand why the selected models in the app work so fine, and the standard models gave problems.

It´s still some of a mystery though, that for a period ( around two weeks ago) a little trick could make our own models perform fairly well from the webbrowser, now this feature is of, the site reloads when I try to view my own models from the webbrowser.
(The trick was to Request Desktop Mode, and then it performed quite well.)

The standard web-version also performed perfect on the PC-based Oculus Rift, also with the Oculus Rift controller which could be used to navigate in the scene.
The Oculus Go controller works in the VR app, but not in the standard web-version.


(Skyeshark) #35

Would really love to see proper Oculus Go support. I have a few scenes on my sketchfab meant for viewing in VR and they always worked super well with mobile VR, but unfortunately, on the Go, I get the same crashing error others have mentioned. Would really like to see those scenes of mine on it!


(U Double U) #36

+1
If I were Sketchfab and had just opened a store I‘d make sure that all 4 or 5 main HMDs and OSs would always see a perfect model and would be able to navigate in the scenes. Especially the Oculus Go, since it seems the the best of both worlds. Having a good resolution and a separate, familiar controller.
Just my 2€…
I love Sketchfab, by the way.
Cheers


(Lpdenmark) #37

Wonder if the Oculus Go have been blocked by purpos, some weeks ago it worked but with some issues, but now it doesen´t work at all, the browser reloads the model and you can´t view the model in VR.

It still works in the PC based Oculus Rift.


(Iillee) #38

Would it be possible to revert back to whatever was working last month? Any functionality is better than nothing.


(Skyeshark) #39

I just noticed, why does this say solved when it isn’t? O:


(Lpdenmark) #40

I had the same thought, it´s not solved :slight_smile:


(3DPipelineStudios) #41

Ya that really sucks. There are some work arounds but nothing native anymore I guess. It really didn’t work well enough to be used, no V-Sync paired with a 821 snapdragon causes big problems.


(U Double U) #42

Most models crash the Oculus Go browser so we can not even look at them in VR. What‘s happening?


(Iillee) #43

So which headsets work best in place of the oculus go?

Im considering biting the bullet and buying something else… I have clients that want to use this!

Is there an update coming soon?


(Tl0615) #44

Daydream works well enough. Annotations do not trigger. Teleport works and there is vertical scaling with LT RT dpad. Running on Pixel XL Snapdragon 835.