Oculus quest 2 for Sketchfab

Hello everyone,

We are looking at the Oculus Quest 2 for viewing Sketchfab models. Just wondered what people’s experience is, does it run smoother than on the original Quest, which seemed to have some performance issues? Thanks in advance!

1 Like

It looks terrible using Quest 2. Images fuzzy, slow update, parts of models move slower than others.

1 Like


It sort of works, but heavy poly models start to lag and sometime crash the browser. Also image ghosting somewhat present. And the resolution is low compare to computer screen experience. I’ve tried using firefox and found Oculus native browser work slightly better actually. But I have to say its still awesome experience that you can literally walk around the models.


I just tried viewing my first architectural model in VR using the Oculus Quest 2 on the default web browser, and the image was quite fuzzy and overly bright - not very pleasant to be in there.

On a different note, it would also be nice to be able to grab and spin the model with two hands, if possible!

I think they should update so that the oculus quest 2 doesn’t look too fuzzy or the quality doesn’t show any lines moving. They should improve it

We released an update for the Quest 2 a few days ago - please have a look and let us know if this improved things for you?

1 Like

It is still the same though. The lines move when I am in VR.

What model specificaly has “lines moving” ?
can you try adding ?vr_quality=1 on the url in the oculus browser

Any update on this? I too am keen to see how the Quest 2 works with Sketchfab. I have the original Quest, which used to work in high resolution if you selected the desktop version. This no longer works and the image is still shown in low resolution, albeit with a bit less lag.

1 Like

Hi Paul! I just discovered Sketchfab for my quest 2 about a week ago and I have to say it is fabulous!

It’s not perfect and some models still “glitch” my headset, but most work ok. There is an issue with the headset “jittering” even when not in VR while on the Sketchfab website.

I would love to have a conversation and even help you evaluate and provide feedback on this.

I have just released our new website which teaches beginners how to use VR and love to provide our visitors with new experiences. Sketchfab is one I am working on right now. We were in it yesterday and due to the jitters, one of my friends got sick really fast and had to quit.

I intend to post a warning about that in my description so people can be aware. If you think I could help, or just want to chat about helping me with content about Sketchfab, please reach out.

I do have one question. I was hoping to be able to hold the object in my virtual hands and enlarge/shrink/rotate it so as much as I enjoy it, that was missing. Is that something we could expect to be able to do in future.

I found a sort of workaround which is to download the public domain ones and import them into Gravity Sketch. I need to refine this a little and would love to speak with anyone that has more experience with that. :slight_smile:
Thank you for the wonderful app!

On quest2 it’s confirmed as solved, but “desktop mode” is not.
For Quest1 we didn’t reproduce, would you be able to confirm it’s the same bug, by checking if you have it on animated model and static model, on only on static models ?

Please start a new thread if it a separate question.
On Quest2 there is no more bugs, but for the fact that VR mobile Headset doesn’t support complex models. In that case it’s best to use a VR headset linked to a powerful desktop, with a powerful gpu. (for quest2, using oculus link).
It’s not possible to hold in hands objects, and not planned for now, but you can scale the scene using the controller stick.

1 Like

I was able to access sketchfab from the Oculus browser but I couldn’t move around or zoom in in the 3D model I had loaded. It’s like I was just looking at a static JPEG.

Is there an app I should be using to view sketchfab models in the Oculus Quest 2? Or maybe the stick controls can be used to move around and I’m just too daft to figure it out?

You should be able to teleport by pointing at the floor and using trigger:


This is very uncomfortable way to navigate vr. O don’t want to always have to walk around models. It’s tiring if I’m looking at a lot of models in one day. Why can’t we rotate the model? I can’t use your browser to look at models. Like someone else has said, I have to download models to look at them and it’s very time consuming. Have you considered that there are also people with mobility issues that use vr?

1 Like

I can not see the description of labelling of my models and difficult to rotate them…
I can not interact with my models as I wish in oculus quest 2

I have only just got a Quest 2 (upgraded from original Quest) and appreciate that the models are more fluid. However, as said above, the annotations are not visible. It is also still in low resolution and changing to desktop mode no longer improves this. There is no reason why the Quest 2 should not be able to display a low poly model in full resolution. Is anything likely to happen about this or is this down to some other limitation?

  • Quest2 is still a mobile phone as a headset; nothing near what a Desktop Graphic Cards can deliver
  • do you have an example model where you cannot see annotation ? do you mean actuall annotations or the text label once clicked on the annotation
1 Like

Hi Paul, thanks for getting back so quickly. Here’s an example:

This has a fairly low poly-count compared with versions I use on a PC. The annotations not only tell you what you are looking at, but also allow navigation around the model. This is not accessible on the Quest 2. The resolution limit, for low-poly models, is surely limited by the fill-rate of the GPU, which must be sufficient to run at full resolution or it would not work in any of the games. It would be nice to at least have the option.

Thanks for the report, we can reproduce the bug and will look how to fix it.
About performance, problem is to compute how complexity will make it stutter, as 3D in a web browser is hindered by much more performance impacting obstacles than native oculus games

1 Like