Oculus Quest browser viewing in VR is no longer possible

Since today, I can not see any 3D models from SketchFab in VR on the Oculus Quest using the Oculus browser. Here a recording of what I see

, first with the browser in Desktop mode and then in Mobile mode.
I re-set the Quest to factory defaults, to avoid any risk that my browser was somehow messed up.
Still the same problem.
Then I tried Firefox. There VR worked as it should.
I am currently making a video tutorial for architects, how they can use SketchFab for their work.
This tutorial will lead to a lot of interest. My earlier tutorial lead to 120k views.
This VR viewing with Sketchfab is essential for this tutorial.
It really needs to be stable.
Can you please make it part of your testing procedure?


Yes, I noticed the same condition on the Oculus Go. It was working perfectly before, why the change?
It’s no longer possible to correctly view VR180 using the standard Oculus browser on Sketchfab.com.

Thanks for the report, after checking out, we saw that Oculus decided to stop supporting WebVR API on their latest update to the browser. ( https://twitter.com/jacobrossi/status/1255306444712349696 )

We have to migrate our codebase from WebVR to WebXR to make it work again, we are working on it to be able to deliver it as fast as possible.

Meanwhile there is no other way than use “Firefox Reality” browser instead of oculus browser:


hi paul, is it possible to notify us when the migration to WebXR is done ?

many thanks therefore, and to the sketchfab-team, while solving this.

sketchfab is great in viewing my own creations with oculus go, but without webvr
my oculus go is useless. i have installed firefox reality but it is slow and the view is shaking at start.

Hi, yes I’ll post there, no problem

Hi, WebXR support is now live on Sketchfab

Great news!

It’s a wee bit shaky, but I’m sure it will continue to get better.
Thanks a bunch to the whole team!

1 Like

That’s great, Paul!
I tested a few models and they work fine.
I think the performance has even gone up a bit.
Thanks, for the update!

Hey all,

So using Oculus’ browser will load a model, navigation seems to basically be broken. I can’t figure out how to rotate the model, turn around, etc. etc. I can teleport but nothing so far works to rotate my POV. Can’t zoom, etc. etc.

Is this a “me” problem or is the VR viewer just broken?

Seems like a MAJOR miss to not support the single most installed hardware and browser in the world…

Welcome @vrmunkey,

it works on oculus browser, teleport is the way to move around.
Scaling works with the joystick.

There is no rotation, nor model turn, you need to walk around models like in a museum.