Oculus rift mode isn't working correctly


(Grimbode) #1

Description

I have dk2 so I added /embed?oculus=2 at the end of my sketchfab model url. Now everything seems to be working correctly except when I go full screen:

When I go full screen the canvas goes full screen, but the 3D model on the canvas doesn't.

Worth noting

The curious thing about this is when I don't modify the URL for oculus mode, it works fine.

Question

What am I doing wrong, or is this a known bug?

For more information feel free to check my stackoverflow post. I added more information there about the issue. Thanks.


(Stephomi) #2

You are trying to use the hard coded version of the oculus and we probably won't support/improve it.
It was very experimental at that time.

The good way to test VR is to get a browser with VR support.
Then you will see something like that :

Right now VR support in browser is still experimental so you have to download a custom build of chrome/firefox.
For chrome : (just take the last build, it's a portable version so it shouldn't conflict with other chrome version)
https://drive.google.com/a/sketchfab.com/folderview?id=0BzudLt22BqGRbW9WTHMtOWMzNjQ#

For firefox it's already in nightly, with an add-on for now though : (i didn't test it but it should work fine... I guess)
http://mozvr.com/downloads/

If it's not already done you probably need to install "Oculus runtime* :
https://developer.oculus.com/downloads/


(Grimbode) #3

Thank you for your answer.

Trying the embed with the custom chrome ( chromium ) and firefox ( firefoxnightly ) was one of the first things I tried. I should have mentioned it.

What I tried:

When I try launching the viewer in firefoxnightly ( pressing the 3D button to start ) it'll load up to around 38% and stop there. It won't go any further.

When I try doing the same thing in chromium the browser just crashes.

I installed "Oculus runtime" and it doesn't seem to have fixed the problem.

Question:

Do you have any ideas where this problem may be coming from? Any additional suggestions?

( I have other VR projects I am working on that work fine with firefoxnightly and chromium )


(Stephomi) #4

Oh that's weird. You mean it's crashing before you even click on "virtual reality" ?
Is it crashing on the main website too (or only for embeds?)
Can you paste the error output in the console?

Thanks in advance.


(Grimbode) #5

That's correct. I unfortunately don't get the chance to click on virtual reality. I am on Mac. I am about to test it on Windows in a bit.

At the moment here are some screenshots from Firefoxnightly:


FireFoxNightly Console:


If you want me to try and get something from chromium before it crashes I can try. To be more specific on how chromium acts:

When I click 3D model ( the start button ) It hops from 1% to 100% instantly and then crashes.


UPDATE:

After a couple refreshes it seems to be working on FireFoxNightly. It does not work when I directly open it up.

In chromium it'll still crash no matter what.


(Stephomi) #6

Indeed I tested nightly and I had the same error (but only when I didn't have any oculus plugged in).
This error should be fixed on the next release.

However for me the VR mode didn't work out in firefox, (even with the official webvr firefox demos, so maybe it's a problem on my computer/config).
Only the head tracking worked (both the official demo and sketchfab).
We have an "HD prototype", so it's not the lastest version, maybe there's some differences.

For chrome, it should work (it worked for me :)). Can you paste the error in the console?
The custom chrome build is very unstable but with only one tab opened you should at least see the model.

Anway, we'll probably put more effort on VR support once the webvr browsers are more stable, but still early feedback are welcomed.


(Grimbode) #7

Hey Stephomi thanks for the response. Yes, it would seem that I have to have OR plugged in for firefox to work properly.

Chrome is not working for me, there are no console errors before it crashes. It just instantly crashes. I'll just use FirefoxNightly for now till ( like you said ) webvr browsers are more stable.

I would like to congratulate you guys at sketchfab. Really good job with the whole embeding/sharring system for 3D objects. Saving me a lot of time. Keep up the good work.

I also added the response to the stackoverflow question


(Stephomi) #8

Thanks for the feedbacks !