Sketchfab Forum

Odd display behavior for model on smaller screens


(Mindless Pursuits) #1

I'm new to Sketchfab and relatively new to making my own 3D models, and I'm experiencing a behavior I cannot figure out the cause of. I created my coffee mug in Blender 2.78, UV unwrapped it, made certain my scale was applied, then exported as an FBX. I then imported it into Substance Painter and textured it and baked it. I exported the textures to Unreal Engine 4. In all of those environments, the model displays cleanly and looks good.

I then found out about Sketchfab and joined, and uploaded the model. On a desktop, it looks great in the browser, but on my iPad, it has issues. In landscape view, it displays with a lot of green lines showing through the picture side of the mug. If I try to go full screen or turn on HD textures, it crashes the browser tab. This is true in both Safari and Chrome. I have tried reducing the texture sizes to 1024x1024, changed the normal map mode to OpenGL, re-
exporting the FBX, and re-painting and re-exporting from Substance. Nine have solved the problem. I'm at my wits end. Help?

Here is an image of what is happening in landscape mode: https://www.dropbox.com/s/xwt0evlg7l9cdp2/IMG_0332.PNG?dl=0


#2

Hmm, weird.

I turned off transparency on all your materials and it seems ok now...

@stephomi ?


(Mindless Pursuits) #3

That IS odd. I wouldn't have expected that to be an issue. I still crash sometimes when going to HD. I'll keep playing and keep an eye on transparency. Thank you for the help!


#4

It's probably a rendering bug on iOS.


(Mindless Pursuits) #5

I suspect you're right. I'm going to mark this as fixed. Thank you for the assistance!


(Stephomi) #6

Depending of the textures size, HD can be pretty huge and can easily exceed the total VRAM of your GPU, so it's not really surprising.