On IOS, textures get black blinking!


(Www Noe 3d At) #1

iPad and iPhone (iOS 11.4.1) same problem. When you start moving a model the textures are flickering black, when the model stop moving, textures are ok.


#2

Sorry about that, it’s a known issue and we’re looking for a fix. @paul_sketch might know more.


(Www Noe 3d At) #3

Thanks, hopefully you are able to fix that soon.


(Ondaka) #4

Same problem here. Except the flickering is white sometimes.

iPad pro’s, iOS 12.0 and 12.1


(Ondaka) #5

Is there any update to this bug? What is the eta on a fix? We’re showing work to a very large client on Thursday (Tomorrow!) and this is very bad.


(Sameerhazari) #6

@James @paul_sketch
Guys any updates on this issue?
This is happening everywhere on iOS 12. iPad and iPhone. Safari and Chrome.


(Ondaka) #7

Looks like turning off antialiasing helps with this for our models. (in post processing filters)


(Www Noe 3d At) #8

Yes, you are right. But i dont like to change this settings for my 450+ models. But maybe your tip will help to fix it quickly. Yesterday i thought it will be fixed in few hours. But till now, nobody from the SF-team tell us some news. :frowning:


(Darlighting) #9

When will this be fixed? After a lot of research I’ve decided to use sketchfab to offer our catalogue in 3D on presenting this we find all black artefacts very embrassing, i guessed its a serious problem and would be fixed by now but still the same. We’re obviously holding off until this is fixed.


(Rory Baxter) #10

I only noticed this today when showing a colleague my Sketchfab models and animations - a seaweed texture is flashing in an animation like two polygons sharing the same space


(Farabi Adworks) #11

Same issue here. No problem with Android devices. Also iphone 8 no problems. But every other (older) iphone seems like it can’t render the textures (tested with 6 and 7 series).

So is there a fix on the way? When? Thanks!


(Rory Baxter) #12

I viewed on iOS devices too - iPad Air, Air 2, iPhone 7


(Public Art Uk) #13

Big problem lads, can you please advise us on your course of action? It makes your customers look like fools, something as bad as this requires urgent action. PLEASE REPLY SOONEST


(Munch) #14

Deactivating temp. AA in Postprocessing helps…
only needed for devices older than iPhone8…

Dear SketchfabTeam, it might be a good idea to set this flag NOT by default!

thank you


(Www Noe 3d At) #15

Deactivating AA can help, buying and iPhone 8 can help too. But this is not a fix. The main reason for me is, why nobody tell us some news?? I am very disappointed in the silence on the part of sketchfab about this problem.


(Paul Sketch) #16

We finally have the fix and we plan to release it tomorrow.


(Www Noe 3d At) #17

Thanks for the status.


(Rory Baxter) #18

Thanks for the update Paul


(Www Noe 3d At) #19

Great! All is working like it should.


(Paul Sketch) #20

The fix is released and live on sketchfab.com