Opacity setting stopped working


(Kaleidoscope) #1

Hi! I’d like to report a strange behavior of Sketchfab on my model, I mainly wanna understand if it’s a bug or a mistake of mine!

I uploaded this model a few time ago: Sayuri and Kota - 3D model by Kaleidoscope (@kaleidoscope) - Sketchfab

It has an opacity map that is supposed to create a cutout on the girl’s prop: it worked fine at first but today I noticed the opacity map “stopped working”, without really doing anything. I tried importing different versions of the map, even tried changing from alpha to luminance with strange results: when in Luminance the map makes the whole model disappear, and if I invert the map it only shows the black cutout. Checked the texture alignment but everything seems fine.
Thank you so much!


(Paul Sketch) #2

Welcome,

In order to fix the model you can use:

  • dither with texture set as luminance
  • mash with texture set as luminance but reduce intensity slider to 0.98

(Kaleidoscope) #3

Thank you for your super fast answer!
Used the mask method and it worked like a charm. Thank you so so much for the solution!