Partially flat shading issue

Hello. I have set shading in blender to smooth and when i upload to sketchfab, most of the model looks as expected but the area between light and shadow appears to be flat shaded. When using matcap this issue is not visible. Here is the model:

And another model but the problem is less apparent:

Is this an issue with my models or just how sketchfab rendering works? How can I solve this?

There is a shadow bias setting which makes shadows sharper or softer. Or make your model a higher resolution. Sketchfab is designed to work for any device, even mobile phones, so the quality may not look the same as it does in blender or any other software

1 Like