Particularly bad compression Issues


(Ironbelly) #1

Uploaded and setup a new model last night and once published I was surprised with just how bad the compression issues are.. I've voiced concern in the past over this issue, but this particular model's are so bad that it's preventing me from showing this publicly at all.

You can see it here

Combine Lexion 480 by Ironbelly Studios on Sketchfab

The side around the door is particularly bad but there are issues everywhere


#2

HD mode looks great to me, but there a A LOT of big textures here, so it defaults to SD, which doesn't isn't so great.

CC @marc @stephomi the resized textures here seem to have some bad artifacts :confused:


(Stephomi) #3

It's not really a compression issue but a resolution issue...
The model has around 25 textures, all 4k. That's huge!

As @james said, in SD mode, we'll take a lower resolution so that the model doesn't crash the devices it will be displayed on.
For this model, in SD mode we'll take only the 1k.

So the solution is either to select HD mode or using more reasonable texture sizes.


(Ironbelly) #4

Ah, first of all I didn't notice it was auto-selecting SD, in HD it does look better albeit not perfect.

'Reasonable' is a subjective term. When we have clients in the visualization space looking at this on a 4K projector we want to make sure everything is as crisp as possible. It's not so much about being unreasonable as it is about doing what is necessary to meet the needs of our clients.


#5

Fair enough. Most important is to make sure HD is selected.

Could you post some screenshots showing the texture issues in HD?


(Ironbelly) #6

Strangely enough now I dont' have any SD/HD options available when I open the file: http://i.imgur.com/HLup5BO.jpg

Looks like it's displaying the textures at full resolution which means there are zero texture issues, everything is crisp as a cracker. Is that supposed to happen?


(Ironbelly) #7

Ok, the options are back now.. The compression seems more noticeable on the red/white diagonals.. I put together some shots here: http://i.imgur.com/baP8UdJ.jpg


(Stephomi) #8

By "Reasonable' I meant textures that won't crash most of the devices (mobile or not).
We don't put HD by default, because we don't want people to have their web page crashed when they browse models on sketchfab.

But in your case, your model is private and you have full control on the device where it will be displayed, so indeed it's not an issue and HD should be selected :smile: .

Two things to know :

  • In the editor, we always select the original textures, not the compressed ones
  • The compressed textures are created each time you hit "save settings", it can take some times, so you might have to wait a bit before the SD/HD button appear

You can add an option to force the use of original texture, it's not documented and we don't really advise to use it (especially if many people will browse the embed):

  • imageCompression=0 (don't use compressed textures)
  • preload=1 (don't display the model until all the textures are downloaded)
  • pixelBudget=0 (use max resolution textures (HD))

So in the end :

https://sketchfab.com/models/c937633725314c57b1ceada215868c09?imageCompression=0&preload=1&pixelBudget=0