PBR and Classic rendering look the same (lighting)

lights

(Wojna Sandra) #1

Hello! I’m trying to light my scene but the moment I change the default light anyhow (manual and environment) it becomes almost shadeless, like in the classic mode. Notice how they’re on the same settings and the PBR and Classic look the same :frowning:


#2

Hmm, I could not reproduce this issue.

Is it happening on all your models?

Can you tell me exactly what steps you take and settings you change to make that happen?


(Wojna Sandra) #3

Yes, it’s happening to all of my models.
It seems to be a 3d editor issue -

1st way of making this happen

  1. Open 3d settings
  2. Go into lights > environment
  3. Switch from e.g. Milkyway to QueenMary (works okay)
  4. Switch back to Milkyway
    After doing this it looks like my model went into classic mode even though it’s in PBR

2nd way

  1. Open the 3d settings
  2. Go into general > rendered
  3. Set it to Classic from PBR
    When I try to switch back from Classic to PBR again it stays the same

However! When I saved my model settings, it’s in PBR on the website just as I wanted it. It’s annoying that I don’t see the light in real-life though, when editing


#4

Perfect, thanks!

1 - Ok, it looks like the Brightness and Light intensity settings are not preserved when you switch to (e.g.) QueenMary, then switch back to Milkyway. I suspect that these are being reset to the default settings. I’m not sure what the behavior here should be.

2 - This does not seem to be the case when switching between PBR and Classic and back to PBR. We will investigate!


#5

Just to confirm: only in the second case did saving settings still give you the proper result?


(Wojna Sandra) #6

Just checked and in both cases saving gives me proper result. It’s just that it messes up the 3d editor and I have set up the lights first, save, quit and then come back to it if I want to work on other stuff like post processing settings, materials etc.


#7

Thanks. Our team has reproduced the issue and we’re working on a fix!


#8

Actually, the PBR <> Classic <> PBR issue should already be fixed.

The problem with changing the the environment is more about the behavior of the editor, but I’ve reported that as well to see if we want to change that.