PBR Transparency Help?


(Maus) #1

I am not sure how to fix the transparency on this model so that the iris will draw properly behind the cornea:

WIP - Eyeball (Substance/Mesh) by Maus on Sketchfab

Any help would be greatly appreciated.

Thanks!

^^

Maus


(Maus) #2

So I am going to try splitting the iris/eyeball meshs as suggested here:

^^


(Stephomi) #3

There might be an issue with our texture compression too.
Is it working better when you are in the editor?


(Maus) #4

Separating the meshes seams to have worked:

WIP - Eyeball 02 (Substance/Mesh) by Maus on Sketchfab

However things did look a bit different in the editor. I had to set the cornea material to transparent "on" and the iris to transparent "off" to get it to work on the post. Though in the editor this made the cornea appear as if it where solid, but it looks fine when not using the editor. So that was weird?

Thanks for your help!

^^


(Stephomi) #5

When you hit "save settings" we generate compressed texture for faster loading in the viewer (it might takes a few minutes to generate sometimes though).

However in the editor we don't use the compressed textures, so it should always work.
If it's not the same in the viewer, then it's probably a bug on our side.

In your case you should set your opacity texture format to "Luminance" instead of "Alpha".


(Maus) #6

Cool thanks so much for all your help.

^^


(3DGEOM) #7

@maus really nice work on the eye-- I would love to hear what your application for this is. I am working on the #printhuman project ( you can follow our twitter feed, and it would be nice to have models or textures from you and not sure what your fee is -- or alternatively, if you ever would like to collaborate in some way.

Great to see some cool anatomy growing on @sketchfab1 @alban


(3DGEOM) #8

and yes that would have been my guess is to separate the mesh and try again. IS that all you had to do fix that error you were getting?