Sketchfab Forum

Pitch Black Scene

viewer
3d

(Inigmas Studios - Graham) #1

If relevant, PLEASE include the model URL and other information so we can quickly investigate. Thanks! :smile:

Model URL:

2x Pine Tree - Commission! by Graham3D on Sketchfab

Browser:
Google Chrome / AdBlock and AdBlock+ are both disabled on this domain.

Operating System:
Windows 7 64-bit

Description of problem:
I cannot for the love of me figure out why my model on Sketchfab is appearing completely black, even the background is black... When I go into the lighting settings, "Lighting" is disabled... In-fact the only way I can see my models is if I toggle the wireframe on for them... I also noticed that other models that DO work are also appearing fully black as well like this. I am exporting everything like I normally do and uploading the same way I always do as well, nothing new is being done in the process, so I am thinking this is on Sketchfab's end.

See screenshot for lighting example:


Black models with classic shading, only in chrome
#2

That's strange, the model is behaving correctly for me:

For what it's worth, lights won't do anything in Shadeless mode.

What version of Chrome are you on? ( chrome://help/ )
Do you see the same thing on other browsers?

Can you please send me a screenshot of this report? http://webglreport.com/

As well as the Developer Console log during the page/model load?

It's not clear what you mean "other models": is this happening on ALL models for you? Just some models? Can you test the models on this page?


(Inigmas Studios - Graham) #3

Chrome Version:
Version 49.0.2623.87 m

I think I did it right with this screenshot showing the console log. I have not tried it with other browsers.


(Frigokilla ) #4

Browser:Chrome

Operating System:Win 10

Description of problem:I can only see black models when I try to view a scene with classic shading. It only happens in Chrome and only on this pc. When I change my own scene and apply a transpancy to it and set this to alpha masking, I can see my object, when i set this to alpha blending it disapears again.
Sometimes i can see the textures flickering through. Think it's something with a chrome setting. Any ideas?

Thanks in advance


(Bart) #5

@Frigokilla I've merged your message into an existing discussion - it seems you're not the only one experiencing this. Please help us by providing some additional information - see James' request two messages up.


(Frigokilla ) #6

Hello, it seems that it has to do with the Chome version. I've checked and on this pc chome is on the latest built 49.0.2623.87 m.
On my laptop chrome runs on the 48.0.2564.116 m built and everything runs fine there. Hope this might help


(Frigokilla ) #7

I just did the test with all the different models and i can see every model except for the ones in the beginning. Those with no postprocessing.
Here is the web gl report

This is the java report.


#8

Interesting.

@graham3d @Frigokilla if you turn post-processing on on your own models, do they work?


(Inigmas Studios - Graham) #9

Toggling post-processing on and off didn't do anything; however though, toggling "Fixed Background" OFF made the the models appear...


(Frigokilla ) #10

when i tun on post processing filter initially it doesn't work.
But when switch on the following it does:
- sharpness
- chromatic aberration
- bloom
- tone mapping
- color balance

Also as @graham3d posted, switching of the fixed background made the models reapear