.PLY texture not loading

vertex-colors
viewer
3d

(Elbriga) #1

Model URL:

the Altar (MagivaVoxel bake) by elbriga on Sketchfab

Description of problem: I uploaded this model a few days ago trying out the new magicavoxel .PLY export and it seemed to work fine, but earlier today I noticed all texture had disapeared, I re-uploaded and it was fine, now again, no textures... strange!
@gustavo_san reported the second problem, I'll try to re-upload but I'd rather report in case there's something to investigate ^^


(Gustavo San) #2

I managed to make materials appear by uploading th .mtl and .png I got from an .obj export, but somehow I think that affects the bake (for example I have material emmissions on the .ply file that don't show at all).


(Elbriga) #3

I tried that but it didn't work :confused:
It's really weird that it worked and then not :stuck_out_tongue:

I think the bake doesn't take material emission into consideration so that might be normal ^^


(Elbriga) #4

well damn, I turned on "vertex color" in the general tab and that fixed it... for now? Not sure why it stopped working in the first place though...
@gustavo_san did you try that?


(Gustavo San) #5

funny thing is that your model was working just fine an hour or so ago then, when I re-visited it, it was troubleshooting as you saw.


(Gustavo San) #6

I just re-uploaded the model only with .ply and it works fine! Lets see for how long ^^


(Lrtvri) #7

i had the same problem with earlier uploaded ply model, i've tried your suggestion - vertex color settings - works fine now. Thanks!


#8

We just released updates to Vertex Colors (followed swiftly by a related hotfix) and it broke some stuff along the way. Sorry about that guys!


(Elbriga) #9

mystery solved! Glad it's not a bug :smile: works great now! :smile: