Possible gimbal lock after importing fbx

animation

(Tomschafer) #1

After importing this scene as an fbx the animation in the larger character's right leg goes bad.


(I've added annotations with the points and times.)

I've checked my local files on Maya and Motionbuilder and they playback with no issues. Joint rotation order seems good, but I tried changing it anyway. I've also tried exporting at 60 fps. Does the sketchfab player resample the animation data and apply a different joint rotation order?
Any help would be greatly appreciated.
cheers,


#2

We're investigating some similar animation issues. Do you bake the animation before/during export? A current theory is that when we re-bake an already baked animation, this happens. @mrchlblng or @waleguene would know better.


(Tomschafer) #3

I bake the animation before I export. In this scene, and a few others I've done, it is a necessity. Often the animations will not play on multiple characters or disjointed joint hierarchies. To fix I have to merge the character skeletons into a single hierarchy.


(Tomschafer) #4

I took a look at this scene today, and the animation on the goblin seems to have changed. I'm not certain, but I'm pretty sure I looked over the entire scene for more examples of those animation glitches and found none. Today I noticed some more in the body and foot of the goblin.
Has anything been changed about the animation compression or re-sampling? ...if not, it's most likely something I just missed.
thanks


(Mrchlblng) #5

@tomschafer, we fixed the (known) issues regarding animation. The glitches were due to some compression error that is now better detected.
We also lately introduced some bug in skeleton parsing for models coming from maya but this was just fixed.
You'll need to reupload your model to fix the issues.


(Tomschafer) #6

Thank you very much! I'll give it a go!


(Tomschafer) #7

Much better! Thanks again for your support!:grinning: