Problem Exporting using 3dsmax exporter


(Jonathansty) #1

Hello everyone,

I'm kinda new to sketchfab. I've been aving some trouble with the 3dsmax exporter. I have a high poly scene with 3 objects I want to export but none of my materials are showing up correctly.
I've already contacted sketchfab support so maybe some people on the forum have an idea that I could try.

Also @klaasnienhuis , do you have an idea what I'm doing wrong.

The first one: https://sketchfab.com/models/8a48ecec7ede4f71a6b63f4f7856e171 ( with baking lightning and auto unwrapping)

the second one with baking lightning and without auto unwrapping: https://sketchfab.com/models/d5423a4400c648d082c30b36caf988d3

Friendly regards,
Jonathan


(Klaasnienhuis) #2

Hi J,
it's impossible to say why your materials aren't showing up correctly. What's wrong exactly? This can be caused by anything. It also depends on if you're baking or not. Many material effects (bump, reflectios, specular) are lost when baking and have to be recreated with the sketchfab shaders online. When not baking you have to keep in mind only a small portion of the shaders are ported to 3ds Max. Check out the docs for the exporter to see what's supported and what not.

About the models you've linked to: they both have a huge groundplane. This object eats up the majority of your texture pixels. This is clearly visible on the scissors for instance. The texture is very lowres in that area. Make this object a lot smaller and you'll see a great improvement in texture sharpness. The second model has been baked but not unwrapped if I understand correctly. The script in 3dsMax will happily bake models, even though they haven't been properly unwrapped. This doesn't mean it will look good though. It's best to keep the auto-unwrap option enabled, unless you've carefully unwrapped your model yourself.


(Jonathansty) #3

Instead of uploading the entire scene I'm gonna try upload just 1 object and try out some settings then.