PROBLEM: Unable to get Desktop WebVR working:(


(Swami Mathtraveler) #1

Have attempted in:

  1. Firefox (v49.0.2, as of 28oct2016).

- Per stackoverflow forum post , I installed the ‘WebVR Plus’ add-on purported to enable WebVR in Firefox. But alas, it didn’t work. I even tried the purportedly “simple example” of cubes, but even it didn’t work:(

  1. Google Chromium (v56.0.2903.0 canary (64-bit), as of 28oct2016).

- Alas, this failed, too:(
- Found this Experimental Chromium for Windows. Downloaded/attempted to install, but got this error message:

So, still no success. But not from any lack of trying!:slight_smile: That said, I’ve still missed something. TIA for any help.

VirtuallYours,

Swami


(Swami Mathtraveler) #2

P.S.

Per WebVR info for 'Experimental Chromium Builds', I attempted to "Enable WebVR" using a flag as instructed, but could not locate the flag...


(Rob2) #3

Firefox nightly is working for me as far as getting a fullscreen stereoscopic view goes on a macbook air with OSX 10.11.6 but the device I have to test (Vuzix iWear) is a non starter. What device are you using for display/headtracking ?


(Swami Mathtraveler) #4

Thx, Rob,

MacBook Pro: OS X v10.9.5 (Mavericks), Build 13F1911. No VR system. Just want to see the stereo pair on screen, and check things out on the laptop.

OK, installed FireFox Nightly. Looks like the WebVR is enabled: now I get a button for "Enter VR". Nothing happens when I click it, though. I expected a split screen, but maybe a device must be hooked up for anything to happen. Well, at least I now have one browser that's WebVR capable:)

Thx, again,

StereoscopicallYours,

Swami


(Rob2) #5

No device required as far as I know - my macbook air happily displays fullscreen stereoscopic image when I click the cardboard icon in the sketchfab viewer but navigation seems pretty much impossible - I must be missing something but haven't had the time to sort it out.

I have a cheap VR BOX cardboard device (no switch for navigation) but as my current device is an iPhone navigation is still an issue !!

I was rendering stereoscopic videos from 3D Studio DOS over 20 years ago and watching them with a homemade viewer made from cardboard and the eyepiece lenses from an old pair of binoculars all taped together onto the front of a CRT display. There was obviously no control other than playback but the effect was superb and life was a lot more simple :slight_smile:

A good blog post from Sketchfab on the current state of VR options WITH navigation would be great ( for me at least :))

All the best

Rob


(Swami Mathtraveler) #6

Hi Rob,

Obviously, I need to clarify. Sketchfab VR WORKS FINE FOR ME using Google Cardboard and my iPhone 5:) WebVR is NOT WORKING (no Cardboard involved). At least it didn't work in Chrome, Chromium, Firefox, or Safari. But thx for your suggestion, IT DOES WORK in Firefox Nightly, BUT only sorta: it gives button to "Enter VR" but nothing (apparently) happens.

Here's the error message...

It appears in Chrome, Chromium, Firefox, and Safari, as shown below. The top screen grab shows it "working" in Firefox Nightly...

No big deal. As I said, I was just curious. I'll just leave it aside for now, I guess. But thx again for you willingness to help:)

Swami


(Bart) #7

Be aware that most 'nightly' builds don't contain WebVR support yet. You should grab a special build from http://webvr.info and follow the instructions there to get it working. Public release is getting closer though, fortunately!


(Swami Mathtraveler) #8

Thx, Bart.

Very interesting to see these previously "out of reach" technologies coming to the average user. Seems like it was just yesterday that I was... No, wait, that was 25 years ago! Never mind:)


(Panomedia) #9

Hi Rob!!, i am also quite lost in regard to vr on mobile phone... i can't move forward or change point of view, just the stereoscopic view on the mobile no interactivity whats ever .. How about VRBOX there is a model with a bluetooth remote.. is it working for you?? thank


(Swami Mathtraveler) #10

UPDATE: Desktop WebVR is working! (in Firefox Nightly). Still much to learn about SketchfabVR! Looks like all previous uploads will have to be reworked for the new VR:( Oh well, tech growing pains: just a reality. Fortunately, that will all be behind, eventually... until the next change comes!:)...


(Bart) #11

Awesome, glad to hear that! :slight_smile:

Which viewer are you using? If you have a Cardboard please make sure it's a V2 model - the one that does not have the magnetic button on the side anymore but instead a conductive one at the top:


(Panomedia) #12

Thanxx bart Ok with VrBox, teletransport works perfect :slight_smile: ..my Cardboard is V1 with magnet....that's why it wasn't working...thanxxx.