Problem with Material texture sets


(Uchiha144) #1

Hi guys never posted before, hope you are all doing well. To start off im going to say i never had this problem before and its quite frustrating, basically i modeled a scene in maya did some sculpting , retopo back to maya, unwrapped everything and since it is a little environment scene and has different parts to it i assigned different materials to it in maya so when i import it into Substance Painter ill get a bunch of different texture sets ive always been doing this with my models and never had a problem. this time in painter everything looks fine you can see all the texture sets that were created at the end when everything was finished i uploaded to sketchfab as usual but it shows only 1 material available for edit in material tab and there should be a lot of them since i applied them in maya and they displayed fine in substance. it makes it impossible for me to apply my textures in the editor due to all those materials missing. never happened before every other time it displayed all the materials (texture sets) properly and i was able to upload everything successfully, ive got some screen shots here so you guys can take a look at it, sorry im not great at explaining and my english is not my primary language but i hope you can understand what im talking about, hopefully some of you can help out :slight_smile: ps- i also added a picture of a well that i made a while ago showing example of what the material tab should look like for your reference. have a nice day.


(Waleguene) #2

Hi @Uchiha144,

Thanks for reporting. What do you mean by "as usual", did you use the Substance Painter exporter ? or did you exported the texture sets, zipped it with your model and uploaded the .zip manually on Sketchfab ?

It seems that no textures have been uploaded with the model, and that you probably exeeded the "100 material" threshold so all materials have been merged together into a single one (since there are no texture to differenciate them).

Could you give the number of materials your scene has ? and detail a bit your workflow ?

Thanks,


(Uchiha144) #3

Thank you so much for your reply, now that you have mentioned exceeding the 100 material threshold it seems that could be my problem, i have 107 materials all together so in that sense this model is pretty messy.. and when i said as usual i just meant to say that i always upload my stuff to Sketchfab when its finished :), Yes i used SP exporter the first time and this problem occured i only had 1 material and all the textures were merged into one and i couldnt fix it because all the other materials were not there so i couldnt switch and apply them correctly, after that i tried uploading just the FBX of the model without textures and i hoped the materials would pop up then so i could manually assign textures that didnt work either i tried the same with an OBJ, i also tried exporting the model through Sketchfab plugin in Maya same problem it exports it as ONE material and i dont know why, the model is not combined it is separate and each part has their own material, so it should be working as it always worked for me in the past. in terms of my workflow it always is - Modelling in Maya --> Zbrush for Sculpting --> Retopo if needed --> Back to maya again --> Unwrapping --> Assigning different materials to each part of the model --> export to Substance Painter --> Sketchfab.I never actually uploaded zip's I either upload it to Sketchfab straight from Substance Painter or i upload a obj/fbx without textures and then apply them manually in the editor as i have all the textures saved out in a folder.


(Dark Minaz) #4

Merge a few of those objects to 1 and put them all on the same uv set.


omething like this.

Having a uv set / material for every little piece is overkill :slight_smile:

so 1 for the ground area, 1-2 for the house. That will also make it much better to view as it doesn't have to load so many textures


(Uchiha144) #5

Yes you're probably right the model i put up in terms of materials and so many different pieces is a bit of a mess! waay to many parts.. whereas i should've done what you said, probably would not be having this problem right now.. very frustrating :stuck_out_tongue:


(Waleguene) #6

@Uchiha144 we recently pushed this update to avoid having scenes with too many materials (that makes the scene hard to render on devices). That's why it was probably working before.

Just to let you know how it works:
when the scene has more than 100 materials, we try to merge some of them together (if they have the same properties/use the same textures)
If the count is still greater than 100, we only keep one and drop the others.

As you were using different textures (I guess) on your 107 materials, they have been dropped and only one has been kept.

If you reduce your scene to lower than 100 materials, it will work.


(Uchiha144) #7

Thank you so much for helping me this explains everything then.

Kind Regards.


(Insta724) #8

I had some trouble. Fixed ! Thanks for response.:sunglasses: