Sketchfab Forum

Problem with model I bought


(Joel3d) #1

Just purchased a model from here on SF,

I need the FBX version. However the model doesn’t have any material
applied. it’s just a default grey material. There are various texture
files with the download, but not applied in the scene.
Also, The gLTF format doesn’t open either.

Any chance I can get this before the weekend, need this for a project I am working on.

BTW, I tried to get help via the Help Center but it doesn’t open. I get this
message
Secure Connection Failed
An error occurred during a connection to help.sketchfab.com. Peer’s
Certificate has been revoked. Error code:
SEC_ERROR_REVOKED_CERTIFICATE


(Waleguene) #2

Hi @joel3d

If the user uploaded the model alone and added the textures later through the 3D editor, the binding will not be saved in the original FBX. Also, the model is PBR so if your software doesn’t support PBR materials, you will not be able to get the exact same result.

The only way to get everything bound is to use the glTF archive (which has been generated using the Sketchfab settings), but this file format is new and is not yet supported by all softwares.

Which software are you using for your project ?


(Bart) #3

@kryik1023 Joel could use some help here on a product that you sold,

@joel3d the SSL certificate error has been fixed, thanks for reporting!


(Bart) #4

I had a chat with @kryik1023 and we checked both downloads:

  • The FBX download contains materials, but they’re not bound to textures
  • glTF download contains the textures (but you may or may not be able to import it, depending on your software).

Have you tried applying the textures to the FBX download?