Problem with my shader in transparent areas!

Hello guys,
I am having a problem with my 3D program, or my graphics card, I would not know for sure.

The program I use is “Wings3D”, it is free, in case someone wants to do a test and tell me that it is a problem of my graphic and not of the program, or to confirm that it is the program itself that gives me this fault!
(The problem is not with Sketchfab).

I will explain a little what happens to me, and see who gives me help, or an answer.

I created a tube glass, as a simple example

Deploy the UV MAP

I go to material options, and I slide the opacity.

I activate the "Smooth Shading"
Transparency still looks good here.

I go to faces, tesselate and triangle the object.

Now you can see the problem!

The more polygons …

I’m starting to get bitter all over!
Thank you!!

I am not a Wings3D user, but I think it could be Smoothing Groups.
Or triangulated mesh somehow detached vertices.
Or its just Wings3D settings showing quick render to save resources.

I could test this at home, but it will be only after around 7 hours.

1 Like

The program works in polygons, although you can do some trick to work with non-welded faces.
(But it is not my case, here everything is welding.)

I will show what happens if I export the model, and reimport it to another program or to the sketchfab itself!

Substance

Sketchfab Visor: I don’t know if you can see the Draft version of the object.
https://sketchfab.com/3d-models/vaso-237e0a0840a74591945eab80f727f155

Sketchfab Editor:

I don’t mind waiting for the answer even after 7, thanks Warkarma!

Artifacts are only visible in Sketchfab, if I use / Opacity / Blending
Maybe it will be more helpful.

Hey, I got Wings3D and managed to make a same scene with the same results as you did.

I also tested this mesh in max(exported with obj and imported into 3Ds Max).
3Ds Max was displaying the same problem. So I added Edit Poly modifier and the shading got fixed.
I also found this interesting thing, if you edit normals and reset them in 3Ds Max, it fixes the problems as well.
Is there a way to edit normals in Wings3D? I have no clue where to find it :smiley:

P.S. Why are you triangulating mesh in the first place?

1 Like

Well now that you mention it, I don’t have much idea what can be done with the normals in Wings3D!:thinking:

But I appreciate the information, I will try to comment on this to one of the Wings3D staff guys!

Thank you very much Warkarma, now I’m thinking if I need 3rd prohramas to fix that … damn it!:persevere:

Simply triangulate it in the first place because I knew that even if I triangulate it in the end, I will have the same result!
It is more, never triangle at the beginning, that later I cannot correctly select Loop rings, and so on. :grinning:

Hey, you could always use quads and not bother about triangulating the mesh :slight_smile: . Or you could use Blender which is also free and is so much better in my opinion. There is also 3Ds Max, but it will cost you some money :confused:

Anyhow, enjoy 3D :+1:

1 Like

Normally, only export triangle!
I have “Blender”, but I admit that I find a madness of buttons and thousands of things … :cold_sweat:Wings3D is simplified the truth, it has no news but, I have seen people do amazing things, although it is giving me a lot of can, The normal problem.

Thanks Warkarma!:+1:t3:

1 Like

@ CapAlatriste, it’s hard for me to reproduce the problem in these other software without have your settings. Anyway, that is a common behaviour when you tesselate a object in Wings3D in a situation like this: an object with an outside and inside wall translucent. If you set the opacity to 100% - the “problem” goes; if you make you object solid (even been translucent) the problem goes; You may have noticed those artifacts are present in the inner faces only (not in the external).
Wings3D gives to OpenGL the same settings for any of this situations, but the result is not the same. And as @ warkarma shown, other apps has the same problem too.

Usually, it’s a visual artifact in Wings3D view that may not be present in other apps. When you export from Wings3D, in the menu option for .obj (for example) you can click in the small square at the right side of the item and that will bring you a dialog which you can play with a couple of settings that may help you to export it correctly. Things as “Export Normals/smoothing groups”, that I think if you uncked that may “fix” your problem. Have it a try and check the results.

2 Likes

Hi Micheus, thanks for the answer …
The problem is that if I export those artifacts to other programs, either “Substance”, “Sketchfab Viewer”, and yes, I export, marking: Export Normal, and Export UV Coordinates …
To warkarma, he gave the same problem using Wings3D, and exporting to other programs, but he managed to solve it with a normal hand.
The only thing that tells me this is that thank God it’s not my graphics card.

Maybe I’ll do a test without exporting normal, although I don’t know what will happen.

But because I do not lose anything, before leaving, I leave some information here: I reproduce this artifact error, in
Wings3D 1.5.4
Wings3D 2.1.7,
and surely also in Wings3D 2.2.

I hope I am helpful, since I tried to contact you from the Wings3D forum and it was impossible for me.

Maybe I’ll do a test without exporting normal, although I don’t know what will happen.

That was the idea. By default normal are exported, but you can disable that and then the other app can recreate it. It can “fix” your problem.

I remember that was already discussed in the past, but I still didn’t find the thread.

I hope I am helpful, since I tried to contact you from the Wings3D forum and it was impossible for me.

Do you have an user account active? Then you just need to report it at the bug session. I’m always looking to the forum (every single day :slight_smile:).
If you have any problem accessing your account, then use the email provided in this post.

1 Like

I remember asking years ago about that topic, I think I’m not entirely sure.

The problem is that I don’t remember my password, and I have tried very hard to enter the forum.

So I will contact you by email, to retrieve my password.

And thank you.

1 Like

I don’t think this have anything to do with normals.

Rendering translucent faces (without ray-tracing) needs to be sorted and rendered in the z-depth order
to be displayed correctly most of the 3D tools does not do that, (expensive and not perfect anyway).

Wings render (and exports) faces in the order they where created, when you triangulate a face
you make one new triangle and keep the old face (by making it a triangle).

Thus when you render your model you will render a backside triangle, inside triangle and frontside triangle, backside triangle, inside triangle… and so on.
And it will look like above :-/ the only solution is to ray-trace your rendering.

Changing normals in 3Ds Max probably reorders all faces so that faces close to each other will be close
in the rendering order which look better.

tl;dr rendering translucent faces without ray-tracing is really hard.

1 Like

Thanks for the reply!

dgud: la única solución es rastrear su renderización.

what do you mean by this? The truth is that now you leave me with more doubts than before!

At the moment I know that with 3DS Max, you can “medium” solve my problem.

Is there any chance that in the end you don’t have to leave Wings3D aside?

That is, change the way of exporting? perhaps, unchecking: “Export Normal / Smoothing Groups” when exporting the model.

Or that the guys from the Wings3D team, of some kind of solution?
EDIT: (Sorry Dgud, I just realized that you are a “Wings3D” staff)

If I did not misunderstand, “Micheus” mentioned that it was difficult for him to reproduce the error, I in my case can reproduce it at any time.

And I repeat it is not always, sometimes it happens, anyway I can go back many years, I have to inspect the models and see if they have the same problems.


Here I show, a bottle that I made years ago, and does not give any problem, in the transparencies:

  • The bottle has inner faces
  • Opacity: Blending works fine
  • Opacity: Refraction works fine
  • Opacity: Aditive works fine
    I made the bottle in Wings3D ver, 1.5.4

What I mean is that I don’t believe that there is anything wrong with your model,
if you render it with a real renderer (ray-tracing) it will look good.

But using Wings, Sketchfab or any other tool that uses OpenGL, DirectX, Vulcan or any polygon
rasterizer API you can not render translucent faces correct in the general case.
You can fake it but it is hard to make it look good and it costs performance,
so wings does not do it.

1 Like

:slightly_smiling_face: Thanks you very much

Hmm… Strange. But what about the non transparent mesh looking bad in max after exporting to obj from Wings3D?

1 Like

I don’t have Max so I can’t test, but I didn’t understand there was a problem opaque objects.

Then it sounds like a obj export problem in Wings, inside wings the normals are correct (but those normals are for rendering only) during export the normals are re-calculated.
On the other hand if that was case I should have received some bugs reports, obj is still the most used format.

1 Like

If you need anything from me, then I will try to help in whatever I can …
Either with bug reports or something!:face_with_monocle:

I was looking at Wings3D, observing what types of objects were those that do these strange things to me.


-The error is shown only on objects with double faces