Problem with Sketchfab Exporter, Blender 2.78 + Linux Mint

exporter
blender
upload

(Pauljs75) #1

Using the current release of Blender 2.78 with Linux Mint (Cinnamon, 64-bit), and having problems with the exporter plugin for Blender. (The one included with the Blender install.) Used API key from user profile.

Tried again using the "Claim your token" button, which also had an error:
Import error: No module named 'requests'
That's followed by the file path for the sketchfab addon folder and ___init__.py, with some reference to line 400. (Can't seem to copy the error message directly, sorry.)

File is of a basic environment scene. Haven't uploaded it through the browser at the time of this post.


(Waleguene) #2

Hi @pauljs75,

'Requests' is used by the plugin to handle the upload and all network related functions. It should be included by default with Blender so you should not have this.

Could you try to type 'import requests' in Blender python console and see if it gives the same error ?
On windows, the package is located here:

C:\\Program Files\\Blender Foundation\\Blender\\2.78\\python\\lib\\site-packages\\requests\\__init__.py

On my Ubuntu setup, it's at this path: /2.78/python/lib/python3.5/site-packages/requests/__init__.py

I don't know about the various setup parameters you could have for Blender, do you use a custom setup ?

In the meantime, you can just drag and drop a .blend file on Sketchfab to get the upload working :slight_smile:

Keep us in touch,