Problem with the viewer Sketchfab on a wordpress website with Chrome

wordpress
viewer
embed
3d

(Boulling) #1

Hi !

I have an issue with the viewer sketchfab on my wordpress website. The viewer doesn't lauch all the HD textures apparently or doesn't launch at all (the loading bar stuck in the middle of the loading). I've tried with Edge and firefox, it's working but not with Chrome (worked well before, I don't know why :confused: ). I also tried the plugin where you copy past the ID but same trouble.

Is there anyone who have this trouble or something like this?


#2

Hi !

I'm sorry you're having trouble. Do you have a link to the page so I can take a closer look?

Thanks :slight_smile:


(Boulling) #3

Yes of course : http://www.boulling.com/?p=844


(Boulling) #4

Did you find something ? :confused: Am I the only one who have this trouble with chrome and wordpress ?


(Boulling) #5

It's working now, I dunno why maybe an incompatibility with some wordpress plugins.I change the theme and clean some extensions. I keep you in touch.


#6

Ok great. We've seen a similar issue on some wordpress sites before, related to the way it handles iframes.


(Boulling) #7

Ok good to know. That said, I notice something else with the fullscreen button, it doesn't work. As a matter of fact, no buttons work except the menu one (wireframe, lit, shadeless,...). The others, like the sketchfab icon, doesn't work...


#8

Yeah :\

The iframes are sandboxed to disallow fullscreen, scripts, and external links. Are you using an embed plugin or manually putting the iframe code?


(Boulling) #9

The only thing I do is copying the URL of my model on sketchfab and go to wordpress, use the button "add media" on the article editor, and then I click on "insert with URL" where I paste the sketchfab URL.