Quick Tip: Fixing your navigation by selecting the right 'up' axis

quick-tip

(Gerpho) #1

Another tip worth mentioning is this one :
softwares which produce scans are usually oriented with "z up", whereas the default orientation for creation softwares are "y up".
Sketchfab default orientation is "y up" too.

To have the proper model orientation when importing a scan in sketchfab, one usually has to set "x" to 90° in the "3D settings" menu, "model orientation" item. If not, manipulation will be very awkward, since the mouse movements will apply to the wrong directions, and the model will move rather unexpectedly . Try these two as a an example

Model with default settings here :

Louvois-with "Y up" by Gerpho on Sketchfab

Same model with x = 90° setting here :

Fort Louvois à Marennes by Gerpho on Sketchfab


You can find more Quick Tips here »


Revit to Sketchfab
I can't properly navigate my model
Quick Tip: Improving the lighting of your 3D scanned models
View 3dOrbit tax Topview
(Bart) #2

Thanks @gerpho! I thought this tip was so useful that I broke it out into its own topic smile I'm always struggling with this too.

For those of you who are wondering where to find this option: you will find it in your model's 3D settings. More information about the available options here can be found in our Help Center.


Post a quick tip, win Sketchfab stickers!
(Sumit Tada) #3

Is it possible to do this through the API? I couldn't find any mention of it in the documentation for the data or viewer API.


#4

@sumit_tada - It is possible, but not publicly documented yet because the API is rapidly changing.

Please shoot me an email and we can discuss your needs: support@sketchfab.com


(Rich1) #5

Is this parameter not available in the editor any more?


(Oakwood) #6

I'm having the exact same issue. Can't change the angle of the x Axis.


(Rich1) #7

Well I can tell you that it ain't fixed by upgrading to PRO. smile


(Oakwood) #8

Is it something that needs doing in the model/point cloud itself before exporting?


#9

@rich1 @oakwood I'm not really sure what the issue is here, can you elaborate?


(Oakwood) #10

When navigating the model, it's moving around the z axis instead of the x axis. can't seem to change the x axis to 90 degrees as in the screenshot above from bartv.

3D Point Cloud of a London Street by Oakwood Engineering on Sketchfab


(Rich1) #11

It looks like the UI has changed. The ability to set X to 0 is not available. It looks the feature was available at one time...


I see that my software developer can orient the same model properly. "x=up"

1435605084_PHANTOM60EC7B by Drone Deploy on Sketchfab

my model defaulted to "y=up" and I have no way to change it in the editor.

https://skfb.ly/FnTT


(Oakwood) #12

rich1, your model seems to working fine for me. have you found the solution?


#13

I'm sorry for any confusion. The functionality of those buttons has not changed, at all. We simply split it into 3 buttons. They are still moving at 90° increments (unless you enable "advanced").

Quick video fixing that model:


(Oakwood) #14

That doesn't work for mine.


(Rich1) #15

Hey Oakwood, I wish I know what I did. I had the exact same issue as you.

I have the same issue with this model... https://skfb.ly/DYE8 The default orientation is "y up". I need it to be "x up".


#16

@oakwood you just need to rotate your Y axis 90° counter-clockwise. I've done it for you on that model.


(Oakwood) #17

thanks for that @james, but I was trying to do that and it wasn't working. Thanks very much for the help.


#18

@rich1 on https://skfb.ly/DYE8, just rotate the X-axis once with the "right" button.


(Rich1) #19

James, Your title "Support King" is very fitting! Thanks!!!! I'm off to fix my other model. Long live the Support King!


#20

If you need more help, or think you've found a bug - please let me know smile