Quick Tip: Fixing your navigation by selecting the right 'up' axis

Is it something that needs doing in the model/point cloud itself before exporting?

@rich1 @oakwood I’m not really sure what the issue is here, can you elaborate?

When navigating the model, it’s moving around the z axis instead of the x axis. can’t seem to change the x axis to 90 degrees as in the screenshot above from bartv.

It looks like the UI has changed. The ability to set X to 0 is not available. It looks the feature was available at one time…


I see that my software developer can orient the same model properly. “x=up”

my model defaulted to “y=up” and I have no way to change it in the editor.

rich1, your model seems to working fine for me. have you found the solution?

I’m sorry for any confusion. The functionality of those buttons has not changed, at all. We simply split it into 3 buttons. They are still moving at 90° increments (unless you enable “advanced”).

Quick video fixing that model:

That doesn’t work for mine.

Hey Oakwood, I wish I know what I did. I had the exact same issue as you.

I have the same issue with this model… https://skfb.ly/DYE8 The default orientation is “y up”. I need it to be “x up”.

@oakwood you just need to rotate your Y axis 90° counter-clockwise. I’ve done it for you on that model.

thanks for that @james, but I was trying to do that and it wasn’t working. Thanks very much for the help.

@rich1 on https://skfb.ly/DYE8, just rotate the X-axis once with the “right” button.

James, Your title “Support King” is very fitting! Thanks!!! I’m off to fix my other model. Long live the Support King!

If you need more help, or think you’ve found a bug - please let me know :smile:

I’m struggling to rotate my model correctly i’ve tried the suggestions above and I cant seem to get it to work. can you take a look? thanks https://sketchfab.com/models/00af7fc16a7843bbab43b2bb3eac4271

I’ve fixed it for you, using the ‘advanced rotation’ feature. Enjoy :slight_smile:

wow thank you so much!! :grinning:

@bartv When uploading a model I get the z-up orientation for a regular mesh but if I upload several obj files to create a timeframe animation it all is oriented with y-up and moving around the animated model becames awkward. Is this a bug or is that the intended behaviour? I am asking because though I can fix it myself by rotating the models maybe it is something you are planning on fixing too.

Thanks a lot,

misan

Not sure if that’s on purpose? @marc can you comment?

In any case, you can easily fix that with our orientation settings:

@bartv thanks, I know how to fix it, I just wanted to make you aware of what it seemed to me like an inconsistency on your system (or a feature I failed to recognize).

@misan not sure what you are comparing. When using standalone OBJ or an OBJ sequence in a timeframe model, I have consistent orientation.

It happens however that some software uses different “up axis” and not all formats support (or softwares export) that axis. So what should be consistent is the orientation when uploading a single model vs a timeframe model but otherwise it may happen that the orientation has to be fixed. I wish we could automatically detect the best orientation but not a trivial subject.

If you know a major software for which we have the orientation wrong then please provide us some URL so that we can look if it’s fixable!