Remove Grid on Voxel Based Models


(Elxafil) #1

So I just uploaded my first model and want to show it off but you can't take in the full design with all these stupid lines around each voxel/cube so how in the preview do I remove them?

You can see what I mean here: prntscr.com/i3qimb


(Dan) #2

Good question! It might be different depending on the program you're using before uploading to Sketchfab. Personally, I know you can toggle them off in Magicavoxel. Which program did you use to make this model?


(Elxafil) #3

I used Cubik Studio but when in Cubik Studio I did not have these lines.


(Nomadking) #4

It definitely looks like it’s part of the texture. Is it part of the export or uploader options from Cubik?


#5

Setting the texture filtering to Nearest (mipmap) for both materials in 3D Settings should solve the problem.

Looks like Cubik includes identifying comments in the header of its OBJ files, so we can probably detect this and set mipmap automatically for all Cubik models if this is affecting all such models.

# Export of Cubik Model: Cubik Model
# Designed by Randamonium with Cubik Studio - https://cubik.studio
# from Cubik OBJ Exporter v1.0
mtllib orange_mining_helmet.mtl